[Fix] defineClass's inheritance mapping is broken for abstract class subclasses

RESOLVED FIXED in 1.6R6

Status

Rhino
Core
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Steve Weiss, Unassigned)

Tracking

other
1.6R6
x86
Windows XP

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: Rhino 1.6R5

Bug 333168 has the description.  Attached is a proposed patch, based on the second proposal in 333168's bug report.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

11 years ago
Created attachment 251947 [details] [diff] [review]
Patch proposal

Comment 2

11 years ago
Fix committed to CVS HEAD.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Duplicate of this bug: 333168

Comment 4

11 years ago
Adding target milestone of 1.6R6 based on the date this bug was resolved FIXED.
Target Milestone: --- → 1.6R6
You need to log in before you can comment on or make changes to this bug.