Closed Bug 367390 Opened 13 years ago Closed 12 years ago

MochiKit's this._xhtml should be true for anything that's not tag-soup

Categories

(Testing :: Mochitest, defect, blocker)

x86
Linux
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 386526

People

(Reporter: bzbarsky, Assigned: sayrer)

Details

Sicking suggests:

document.getElementsByTagName('HTML')[0] == document.documentElement

to detect tag-soup.  Possibly along with checking that document.documentElement is in the null namespace and document is an HTMLDocument.

Failing that, just doing

            this._xhtml = (document.createElementNS &&
	                   !(document instanceof HTMLDocument));

will get us the right behavior, but sicking's approach is better.

The regression tests I'll add for bug 311681 will have a .xml file that can be used to test whether this is fixed.  This bug causes the report to not be styled there.
Summary: this._xhtml should be true for anything that's not tag-soup → MochiKit's this._xhtml should be true for anything that's not tag-soup
Depends on: 386526
This bug also causes the results of .xml mochitests to not be counted.  (They show as 0/0/0.)
Severity: normal → blocker
Flags: blocking1.9?
Oh, you already said that in bug 386526.
Jesse why is this on the nom list?
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 386526
Component: Testing → Mochitest
Flags: blocking1.9?
Product: Core → Testing
QA Contact: testing → mochitest
Version: Trunk → unspecified
No longer depends on: 386526
You need to log in before you can comment on or make changes to this bug.