JavaScript Console is misnamed

RESOLVED DUPLICATE of bug 265871

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 265871
12 years ago
12 years ago

People

(Reporter: Elliotte Rusty Harold, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.9
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.9

The "JavaScript console" is far from limited to JavaScript. For instance, it also shows CSS errors and XForms errors (the latter when the XForms plug-in is installed). I suspect other features make us of it too. 

It shoud be given a more generic name. Maybe just "Console" or "Error Console" or "Browser Messages" or some such. However "JavaScript" is misleading. 

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

12 years ago
Fixed in firefox 2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 265871
You need to log in before you can comment on or make changes to this bug.