All users were logged out of Bugzilla on October 13th, 2018

Top level folders with subfolders are indented.

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: laurel, Assigned: hyatt)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+][6/15], URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Using apr21 m16 commercial builds, all platforms

With today's builds, a top level mail folder having subfolders appears indented
(actually the twisty is aligned with the left side of top level folder column).
This has the effect of skewing the alignment for the folder pane, as top level
folders without subfolders align differently.

Looks confusing.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → laurel
(Reporter)

Comment 1

19 years ago
This also holds true for messages in thread pane with replies when in threaded
sort.

Comment 2

19 years ago
reassigning to hyatt.
Assignee: putterman → hyatt

Comment 3

19 years ago
marking nsbeta2 as this can be confusing for users in the folder pane and for 
those users who sort by thread.
Keywords: nsbeta2, regression
(Reporter)

Comment 4

19 years ago
*** Bug 37526 has been marked as a duplicate of this bug. ***

Comment 5

19 years ago
[nsbeta2-]
Whiteboard: [nsbeta2-]

Comment 6

19 years ago
*** Bug 40114 has been marked as a duplicate of this bug. ***

Comment 7

19 years ago
See <http://bugzilla.mozilla.org/showattachment.cgi?attach_id=8962>:

"TrashFolders" looks like a child of "Task", but is a sibling.

Comment 8

19 years ago
It's extremely confusing to the user because you can't tell which is a sibling 
and which is a child folder.  Normally, this would just be polish, but it makes 
the product very difficult to use for everyone.
Whiteboard: [nsbeta2-]

Comment 9

19 years ago
Reading threaded mail/news is a major pain with this bug. It looks to me like 
childless nodes are not taking account of the indentation needed to line up 
with siblings that do have children.

A quick hack may be to put a same width graphic next to all nodes whether they 
have children or not. For childless nodes, the graphic would be transparent so 
you wouldn't see it.

Comment 10

19 years ago
Putting on [nsbeta2+][6/01] radar.  This work must be done by 06/01 or we may 
pull this for PR2.
Whiteboard: [nsbeta2+][6/01]

Comment 11

19 years ago
Changing from [6/01] to [6/15]
Whiteboard: [nsbeta2+][6/01] → [nsbeta2+][6/15]

Comment 12

19 years ago
Mass-moving all dated nsbeta2+ bugs to M19
Target Milestone: --- → M19

Comment 13

19 years ago
trudelle, isn't M19 *after* Jun 15?

Comment 14

19 years ago
trudelle, why M19?

Also, see screenshot
<http://bugzilla.mozilla.org/showattachment.cgi?attach_id=9409>: It is extremely
hard to see the relationships.
(Assignee)

Comment 15

19 years ago
fixed.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 16

19 years ago
hyatt, thanks!

Comment 17

19 years ago
You forgot Unix and Mac in the classic skin. REOPENing. Fix is trival. Attaching
patch.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 18

19 years ago
Created attachment 10100 [details] [diff] [review]
Fix for Classic skin for Unix and Mac
(Assignee)

Comment 19

19 years ago
Check it in for me please.  Consider it approved and reviewed. Thanks
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 20

19 years ago
There is one more issue: It doesn not work in Mailnews for me, either folder-,
nor threadpane, nor account manager. It does work for Sidebar|Bookmarks and
normal Preferences.

hyatt, do I have to get more than your checkin at 06/14/2000 01:47?

Comment 21

19 years ago
hyatt, I have no checkin account.
(Assignee)

Comment 22

19 years ago
ok.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 23

19 years ago
Fixed for generic trees.  If it's still broken in mailnews, they must have their 
own rules.  Open a new bug against putterman.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 24

19 years ago
Yeah, we do, because of the #%#$%#$ changes I had to make to make the @$@#$@#$ 
Mac people happy.
(Assignee)

Comment 25

19 years ago
I put the "empty" rules to hide twisties into the core global rules for trees, 
so they can just bite me. :)
(Reporter)

Comment 26

19 years ago
Opened mail window bug against putterman - bug #43229
(Reporter)

Comment 27

19 years ago
Marking verified for non-mail window.
If specific problems seen, someone can log separate new bug(s).
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.