canvas failing to paint on Windows systems

RESOLVED WORKSFORME

Status

()

Core
Canvas: 2D
--
major
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: daniel newton, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

568 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070118 Minefield/3.0a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070118 Minefield/3.0a2pre

I am not sure why but the canvas element is stopping the browser window to stop repainting at all. I will put up a testcase....

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

11 years ago
Created attachment 251993 [details]
testcase
(Reporter)

Updated

11 years ago
Keywords: testcase
Daniel; checkins (picture disappeared): http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1169009040&maxdate=1169012279
but the picture changed before, in the first half of December 2006 (black line disappeared).
(Reporter)

Updated

11 years ago
Keywords: regression
Works for me on Linux.  Is this Windows only?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070121 Firefox/3.0a2pre

Changing summary and confirming based on conversation with Dan in IRC. On my Windows system, nothing renders when viewing the testcase and the content area is unusable. However, the back button works just fine, so it's not a browser hang.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: canvas crashing page render → canvas failing to paint on Windows systems
This seems to workforme, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070524 Minefield/3.0a5pre

I vaguely remember a similar issue about this.
Definitely works on OS X on trunk. Resolving WFM; feel free to reopen if it doesn't work on Windows.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
This is a windows bug, you can't resolve it when you've only tested it on Mac OS X.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Ah, sorry, I also mentioned this as worksforme in comment 5.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.