Status

()

Core
HTML: Parser
P3
major
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: Doron Rosenberg (IBM), Assigned: Chris Petersen)

Tracking

({crash})

Trunk
x86
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
the site crashes m16 nightly (2000042108) on win98 and linux.  This was not
happening in the m15 release.

The site does have a layer tag, however, since it did not crash m15, i don't
think it is related.

Comment 1

19 years ago
Confirmed with win32 build 042109 under 98.  When viewing the source under 
Navigator 4.7 is has huge empty spaces (up to like 15 and 20 lines) between each 
line of markup.  I taking a wild guess that mozilla's parser doesn't like all 
those spaces.  I'm probably dead wrong but since that sticks out like a sore 
thumb....  The w3c HTML validator had a field day with this page.  There were 
like five errors in the DTD alone.  This page is not the best HTML but it 
shouldn't crash us.  It crashes before anything is written to the console.

adding crash keyword and updating component
Assignee: asadotzler → rickg
Component: Browser-General → Parser
Keywords: crash
QA Contact: jelwell → janc

Updated

19 years ago
Whiteboard: davidr8@home.com simplifying

Comment 2

19 years ago
Created attachment 7868 [details]
Ripped out lots of code, lots of code left, crash fragile

Updated

19 years ago
Whiteboard: davidr8@home.com simplifying

Comment 3

19 years ago
CPetersen: I can't reproduce this. Can you?
Assignee: rickg → petersen
(Reporter)

Comment 4

19 years ago
This has been fixed with 2000050308 on win98. Marking such.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
Verified fixed with WinNT build 072704.
You need to log in before you can comment on or make changes to this bug.