Navigation Toolbar's Manage Search Engine function did not work

RESOLVED INCOMPLETE

Status

()

Firefox
Search
RESOLVED INCOMPLETE
11 years ago
9 years ago

People

(Reporter: Xeonchen, Unassigned)

Tracking

({helpwanted})

2.0 Branch
x86
Windows XP
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Nagivation Toolbar's Manage Search Engine following function did not work
1.Get more search engines...
2.OK And Cancel button

Reproducible: Always

Steps to Reproduce:
1.Start the Browser;
2.Goto Nagivation Toolbar then Manage Search Engine... Button;
3.Click Get more search engines...;
4.Click OK And Cancel button the interface did not close

Actual Results:  
1.Click Get more search engines..., but had not respond
2.Click OK And Cancel button the interface did not close

Expected Results:  
1.Click Get more search engines...,should search for more search engines
2.Click OK And Cancel button the interface should be closed

Updated

11 years ago
Component: Toolbars → Search
QA Contact: toolbars → search
(Reporter)

Updated

11 years ago
Keywords: helpwanted
Version: unspecified → 2.0 Branch
See http://kb.mozillazine.org/Search_engines_disappear_from_Search_Bar
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Version: 2.0 Branch → unspecified
Duplicate of bug: 319196
This bug is reported against 2.0.0.1, and bug 319196 doesn't apply to the search service there, so this can't be a duplicate. Xeonchen, can you reproduce this in safe mode, or with a new profile?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(In reply to comment #2)
> This bug is reported against 2.0.0.1, and bug 319196 doesn't apply to the
> search service there, so this can't be a duplicate. Xeonchen, can you reproduce
> this in safe mode, or with a new profile?
>
So this is not caused by a corrupted localstore.rdf? 

(In reply to comment #3)
> So this is not caused by a corrupted localstore.rdf?

That's right. The Firefox 2 search service and search bar are not dependent on localstore.rdf at all.
Duplicate of this bug: 366045
Christopher or Xeonchen: Do you see any exceptions in the error console if you set javascript.options.showInConsole to true using about:config?
Summary: Nagivation Toolbar's Manage Search Engine some function did not work → Navigation Toolbar's Manage Search Engine function did not work
(Reporter)

Comment 8

11 years ago
I am sorry. There is alert. the content is here: Could not initialize the browser's security component.the most likely cause is problems with files in your browser's profile directory. Please check that this directory has no read/write restrictions and your hard disk is nit full or close to full. It is recommended that you exit the browser and fix the problem. If you continue to use this browser session, you might see incorrect browser behaviour when accessing security features.
Have you perhaps restored your profile from a CD backup, or otherwise done something which would have caused the files in it to be marked read-only?
(Reporter)

Comment 10

11 years ago
I am sorry. There is alert. the content is here: Could not initialize the browser's security component.the most likely cause is problems with files in your browser's profile directory. Please check that this directory has no read/write restrictions and your hard disk is nit full or close to full. It is recommended that you exit the browser and fix the problem. If you continue to use this browser session, you might see incorrect browser behaviour when accessing security features.
(Reporter)

Comment 11

11 years ago
I do not understand the profile, The IE is not the alert.

Comment 12

11 years ago
Suddenly my searchbar disappeard (Firefox 2.0.0.1). Deleted the search.sqlite file, but no use. Opening  "Manage Search Engines..." raises:

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageConnection.createStatement]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsSearchService.js :: createStatement :: line 762"  data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsSearchService.js
Line: 762

Error: uncaught exception: [Exception... "ServiceManager::GetService returned failure code:"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://browser/content/search/engineManager.js :: EngineStore :: line 200"  data: no]

And pressing the Cancel button (which doesn't close the window):

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://browser/content/search/engineManager.js :: engineManager_onCancel :: line 69"  data: no]
Source File: chrome://browser/content/search/engineManager.js
Line: 69
(In reply to comment #12)
> Suddenly my searchbar disappeard (Firefox 2.0.0.1). Deleted the search.sqlite
> file, but no use. Opening  "Manage Search Engines..." raises:

Have you tried a new profile? How about reinstalling Firefox?

Comment 14

11 years ago
Well, I think my post is useless to track the bug. The search engines suddenly reappeared, I don't know why, because in the mean time there were a lot of browser restarts and a couple of computer shutdown and starts. So I didn't manage to test new profile and reinstalling.
Does this bug still happen in recent Firefox releases or with the Firefox 3.5 beta4?
Version: unspecified → 2.0 Branch
Resolving as incomplete. Haven't seen this yet on all platforms. If it still happens for you feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.