Italian language pack requires write access to installation directory

RESOLVED INCOMPLETE

Status

--
major
RESOLVED INCOMPLETE
12 years ago
10 years ago

People

(Reporter: colla, Unassigned)

Tracking

SeaMonkey 1.0 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.8.0.9) Gecko/20061215 Red Hat/1.0.7-0.1.el3 SeaMonkey/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.8.0.9) Gecko/20061215 Red Hat/1.0.7-0.1.el3 SeaMonkey/1.0.7

If I perform a global installation of Italian Language pack, the root user has no problem. Any other user will just see a broken page.
But if the user is given write access to the installation directory (i.e. /usr/lib/mozilla-xxx) by:
chown user:usergroup -R install_path
then everything works fine. 

Reproducible: Always

Steps to Reproduce:
1.Intall Italian Language Pack as root
2.Login as normal user
3.Launch LANG=en_US mozilla - works fine
4.Launch LANG=it_IT mozilla - just garbage (on pink background)
5.As root change ownership of installation directory to user
6.As user launch LANG=it_IT mozilla - works fine
Actual Results:  
If the user has write access to installation directory, the program works fine, otherways only garbage is displayed.

Expected Results:  
I would expect that it's not required to have write access to installation directory in order to work. 

This is not a bug specific of this release. It's there since a long time, and it is specific of italian. I tested french, deutsch and chinese traditional, and they all work properly, without need to readjust installation directory ownership.

Comment 1

12 years ago
Where did you get the it-IT language pack from?

Comment 3

11 years ago
guiliano, do you still see this problem with newer version?
Version: unspecified → SeaMonkey 1.0 Branch
(Reporter)

Comment 4

11 years ago
Up to my last download, (seamonkey-1.0.9) yes, but I may add some more useful info.
I recently verified that the problem is that the .jar files for Italian Language do not have proper permissions. They have access rights 400 (i.e. -r--------) instead of 644 (-rw-r--r--).
The same holds true for the Italian spellcheck files (it.af & it.dic)
Therefore a global installation as root makes the files not readable by other users. A chmod 644 fixes the problem.
If access right have been fixed, than the problem is solved.
I'll download a new version and check, as soon as I have the opportunity.

Comment 5

11 years ago
guilliano, did you tried new versions ?
I seem to remember a bug about needing write access to installdir (in general) but i cannot find it back.

The "traditional" way to install the application includes running it _once_ as admin immediately after installation. Maybe the same is (or used to be) required for language packs? (Note: your en-US language pack would already have run, probably when you installed the app.)

No reply to comment #5 - resolving INCOMPLETE.
Giuliano, if you still see this bug on Sm 1.1.9 or Sm 2.0a1pre, set the "Version" appropriately (2.0 is Trunk) and REOPEN.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE

Updated

10 years ago
Component: Installer: XPI Packages → Installer
QA Contact: general
You need to log in before you can comment on or make changes to this bug.