Some words cannot be selected by double-clicking in bidi text

RESOLVED DUPLICATE of bug 246482

Status

()

RESOLVED DUPLICATE of bug 246482
12 years ago
11 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1 XpcomViewer/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1 XpcomViewer/0.9

Some words can't be selected in bidi text.  A reproducible case I've found is when the direction of a paragraph is set to RTL, and there's some LTR text following some RTL text.

This only happens for me in Firefox 2.  Firefox 3 alpha 1 doesn't seem to suffer from this problem.  I'm filing this bug to make sure that this problem is intentionally fixed in the trunk code (and is not the side-effect of another bug fix, which may break in the future) and to see if it's possible/feasible to migrate the fix in Firefox 3 back to a Firefox 2.0.0.x release.

I'll be attaching a simple test case soon.

Reproducible: Always

Steps to Reproduce:
A sample can be observed in the provided URL, which is a Persian RTL document.

1. Navigate to <http://www.roozonline.com/archives/2007/01/001717.php>.
2. Below the first picture, try to double-click on "Men" in "Children of Men".
3. Below the last picture, try to double-click on "Idiocracy".
Actual Results:  
In step 2, the last Persian word, and the "Children of" part gets selected.  In step 3, the last Persian word gets selected.

Expected Results:  
In step 2, "Men" should be selected.  In step 3, "Idiocracy" should be selected.

about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-official-branding --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-svg --enable-canvas --enable-update-packaging
(Reporter)

Comment 1

12 years ago
Created attachment 252043 [details]
Test case for the bug

As promised.
This is a duplicate of bug 246482, which is indeed fixed on trunk.

This will not be fixed on the 1.8 branch - only security and stability bugs are fixed there.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 246482
You need to log in before you can comment on or make changes to this bug.