If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash occurs when attempting to open this url

VERIFIED FIXED

Status

()

Core
HTML: Parser
P3
major
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Chris Petersen, Assigned: harishd)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Version:2000042011
Platforms: All
Expected results: The page should load at the given url.
What I got: The application crashes.
Steps to reproduce:
1) Open the url specified in NS6.
2) The crash occurs.
3) Note: the assigned doctype for this file is the following: <!DOCTYPE HTML 
PUBLIC "-//IETF//DTD HTML//EN">. This may be causing the problem but cant tell 
since a local copy of this file DOESN'T reproduce the crash when loaded.
(Reporter)

Comment 1

18 years ago
Here is the Call stack on the Mac:

 Call Stack:    (Signature = 0xffc10000 90c345ac) 
     
   0xffc10000 
                                                              
     
   CNavDTD::HandleStartToken() 
                                                             [CNavDTD.cpp, line 
1262]
     
   CNavDTD::HandleToken() 
                                                             [CNavDTD.cpp, line 
709]
     
   CNavDTD::HandleSavedTokens() 
                                                             [CNavDTD.cpp, line 
1686]
     
   CNavDTD::HandleOmittedTag() 
                                                             [CNavDTD.cpp, line 
1217]
     
   CNavDTD::HandleDefaultStartToken() 
                                                             [CNavDTD.cpp, line 
937]
     
   CNavDTD::HandleStartToken() 
                                                             [CNavDTD.cpp, line 
1359]
     
   CNavDTD::HandleToken() 
                                                             [CNavDTD.cpp, line 
709]
     
   CNavDTD::BuildModel() 
                                                             [CNavDTD.cpp, line 
447]
     
   CNavDTD::DidBuildModel() 
                                                             [CNavDTD.cpp, line 
481]
     
   nsParser::DidBuildModel() 
                                                             [nsParser.cpp, line 
647]
     
   nsParser::ResumeParse() 
                                                             [nsParser.cpp, line 
1135]
     
   nsParser::OnStopRequest() 
                                                             [nsParser.cpp, line 
1574]
     
   nsDocumentOpenInfo::OnStopRequest() 
                                                             [nsURILoader.cpp, 
line 278]
     
   InterceptStreamListener::OnStopRequest() 
                                                             
[nsCachedNetData.cpp, line 1154]
     
   nsHTTPChannel::ResponseCompleted() 
                                                             [nsHTTPChannel.cpp, 
line 1539]
     
   nsHTTPServerListener::OnStopRequest() 
                                                             
[nsHTTPResponseListener.cpp, line 630]
     
   nsOnStopRequestEvent::HandleEvent() 
                                                             
[nsAsyncStreamListener.cpp, line 306]
     
   nsStreamListenerEvent::HandlePLEvent() 
                                                             
[nsAsyncStreamListener.cpp, line 97]
     
   PL_HandleEvent() 
                                                             [plevent.c, line 
575]
     
   PL_ProcessPendingEvents() 
                                                             [plevent.c, line 
520]
     
   nsEventQueueImpl::ProcessPendingEvents() 
                                                             [nsEventQueue.cpp, 
line 316]
     
   nsEventQueueImpl::ProcessPendingEvents() 
                                                             [nsEventQueue.cpp, 
line 322]
     
   nsMacNSPREventQueueHandler::ProcessPLEventQueue() 
                                                             [nsToolkit.cpp, line 
132]
     
   nsMacNSPREventQueueHandler::RepeatAction() 
                                                             [nsToolkit.cpp, line 
97]
     
   Repeater::DoRepeaters() 
                                                             [nsRepeater.cpp, 
line 119]
     
   nsMacMessagePump::DispatchEvent() 
                                                             
[nsMacMessagePump.cpp, line 417]
     
   nsMacMessagePump::DoMessagePump() 
                                                             
[nsMacMessagePump.cpp, line 247]
     
   nsAppShell::Run() 
                                                             [nsAppShell.cpp, 
line 100]
     
   nsAppShellService::Run() 
                                                             
[nsAppShellService.cpp, line 364]
     
   main1() 
                                                             [nsAppRunner.cpp, 
line 758]
     
   main() 
                                                             [nsAppRunner.cpp, 
line 968]
(Reporter)

Updated

18 years ago
QA Contact: janc → petersen
(Reporter)

Comment 2

18 years ago
Here is call stack on Win 98:


 Call Stack:    (Signature = nsStr::StrAppend c2cc0141) 
     
   nsStr::StrAppend 
                                         [d:\builds\seamonkey\mozilla\xpcom\ds\
nsStr.cpp, line 173]
     
   nsStr::StrAssign 
                                         [d:\builds\seamonkey\mozilla\xpcom\ds\
nsStr.cpp, line 148]
     
   nsString::Assign 
                                         [d:\builds\seamonkey\mozilla\xpcom\ds\
nsString2.cpp, line 1005]
     
   CToken::Reinitialize 
                                         [d:\builds\seamonkey\mozilla\htmlparser\
src\nsToken.cpp, line 110]
     
   CNavDTD::CollectAttributes 
                                         [d:\builds\seamonkey\mozilla\htmlparser\
src\CNavDTD.cpp, line 1940]
     
   CNavDTD::HandleStartToken 
                                         [d:\builds\seamonkey\mozilla\htmlparser\
src\CNavDTD.cpp, line 1264]
     
   CNavDTD::HandleToken 
                                         [d:\builds\seamonkey\mozilla\htmlparser\
src\CNavDTD.cpp, line 704]
     
   CNavDTD::HandleSavedTokens 
                                         [d:\builds\seamonkey\mozilla\htmlparser\
src\CNavDTD.cpp, line 1668]
     
   CNavDTD::HandleOmittedTag 
                                         [d:\builds\seamonkey\mozilla\htmlparser\
src\CNavDTD.cpp, line 1218]
     
   CNavDTD::HandleDefaultStartToken 
                                         [d:\builds\seamonkey\mozilla\htmlparser\
src\CNavDTD.cpp, line 938]
     
   CNavDTD::HandleStartToken 
                                         [d:\builds\seamonkey\mozilla\htmlparser\
src\CNavDTD.cpp, line 1357]
     
   CNavDTD::HandleToken 
                                         [d:\builds\seamonkey\mozilla\htmlparser\
src\CNavDTD.cpp, line 704]
     
   CNavDTD::BuildModel 
                                         [d:\builds\seamonkey\mozilla\htmlparser\
src\CNavDTD.cpp, line 452]
     
   CNavDTD::DidBuildModel 
                                         [d:\builds\seamonkey\mozilla\htmlparser\
src\CNavDTD.cpp, line 484]
     
   nsParser::DidBuildModel 
                                         [d:\builds\seamonkey\mozilla\htmlparser\
src\nsParser.cpp, line 652]
     
   nsParser::ResumeParse 
                                         [d:\builds\seamonkey\mozilla\htmlparser\
src\nsParser.cpp, line 1149]
     
   nsParser::OnStopRequest 
                                         [d:\builds\seamonkey\mozilla\htmlparser\
src\nsParser.cpp, line 1583]
     
   0x16007004 
                                          

Comment 3

18 years ago
Crash reproduced with the 2000-04-21-08-M15 nightly binary on WinNT.
Talkback Incident ID: TB9183595Z

Comment 4

18 years ago
Another one for the guru.
Assignee: rickg → harishd

Comment 5

18 years ago
Wow.  You weren't kidding when you said "This may be causing the problem but 
cant tell since a local copy of this file DOESN'T reproduce the crash when 
loaded."  The site crashes, but I can't even get it to crash by putting it on 
my web server or as an index file on my webserver.  Also tried saving from 
Netscape instead of from IE (possilbe user-agent check).


Comment 6

18 years ago
The headers may or may not look something like:

HTTP/1.1 200 OK
Date: Sun, 23 Apr 2000 06:25:24 GMT
Server: Apache/1.3.9 (Unix) ApacheJServ/1.1
Last-Modified: Mon, 07 Dec 1998 15:28:20 GMT
ETag: "27194-e79-366bf414"
Accept-Ranges: bytes
Content-Length: 3705
Keep-Alive: timeout=15, max=100
Connection: Keep-Alive
Content-Type: text/html
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
<html>
(Assignee)

Comment 7

18 years ago
Tweaked static method FindSuitableDTD().
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

18 years ago
*** Bug 36871 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

18 years ago
With the April 26th build (2000042611), the page opens and doesn't crash.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.