Font set problem for Korean chars in pulldown of Insert Characters dialog




18 years ago
14 years ago


(Reporter: Teruko Kobayashi, Assigned: Frank Tang)




Firefox Tracking Flags

(Not tracked)




18 years ago
The Korean characters in pulldown menu of Insert Characters dialog are displayed
as "?".

Steps of reproduce
1. Open Composer
2. Select menu Insert|Characters

Under Korean Hangul section , the Korean characters in the pulldown menu are
displayed as "?".  After you select one of the Korean character, the character
is displayed correctly under Insert section.

Tested 2000042109 Win32, 2000042110 Mac and 2000042109 Linux build.

Comment 1

18 years ago
Changed QA contact to teruko.
QA Contact: sujay → teruko


18 years ago
Assignee: cmanske → ftang

Comment 2

18 years ago
I have no idea how to fix this. Help, Frank!
Do we have to set a charset for the dialog?

Comment 3

18 years ago
no. this is a rendering issue. I can see it nicely on my window since I have 
install the office2000 font. blee try it and see ? in his English window but 
without problem on his Korean window (both have Korean font installed). I guess 
the problem is the code use the Unicode Jamo block and some of the korean font 
do not have it. I think this is a rendering issue.

Assignee: ftang → erik

Comment 4

18 years ago
How can this bug be fixed? If there are no fonts with those glyphs on the
system, then we can't draw those glyphs, right?

Comment 5

18 years ago
Forgot to add this comment: 
This works fine in Win NT KO, but not in non-KO Windows with a KO font (Gulim) as well as Mac and Linux.

Comment 6

18 years ago
Given that last bit of info, is showing foreign font sets useful? Is there
a way to detect what language version is being used and include those 
tabpanels only if appropriate version is installed?

Comment 7

18 years ago
How about changing those characters to other characters for which we do have
glyphs in standard Korean fonts? I.e. U+11XX -> U+31XX.
Target Milestone: --- → M30

Comment 8

18 years ago
How come that I only see these entries in the "Insert Character":
Accent upper/lowercase, other upper/lowercase, common symbols?

Comment 9

18 years ago
Mark it as futre
Target Milestone: M30 → Future


18 years ago
Keywords: intl

Comment 10

18 years ago
Changed QA contact to
QA Contact: teruko → ylong

Comment 11

17 years ago
Charles or Beth, I do not see Korean characters in pulldown anymore.  Is this 
correct?  If so, this bug is no longer valid.

Comment 12

17 years ago
erik resign. reassign all his bug to ftang for now.
Assignee: erik → ftang

Comment 13

17 years ago
mark all future new as assigned after move from erik to ftang

Comment 14

16 years ago
removing myself from the cc list

Comment 15

15 years ago
As mentioned in comment #8, I don't see any Korean letters in Insert-Characters.
When did this change happen? If that's the correct behavior (listing only
accented, common symbols, etc), this bug is invalid. 

Comment 16

14 years ago
I can back up comment 11 and comment 15.

It may be too late to make any resolution, but I will close this bug because the
Korean character stuffs were deliberately removed from "Insert Character" dialog
(both frontend and backend) circa August 2000. Relevant CVS windows are:

--> WONTFIX for the bug was valid when it was filed.
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.