If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

addbook: protocol handler needs to support add operation

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
normal
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: marina, Unassigned)

Tracking

Trunk
Future
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

18 years ago
***** observed with 2000-04-21-09 build *****
Steps to reproduce:
- send yourself a message from 4.x with vcard attached;
-get message in 6.0 and click "Add to Personal Address Book" button;
//now notice error message in the Browser window: Unsupported format/operation 
requested for "addbook:" URL.

Comment 1

18 years ago
On my window 98,nothing happens when I click "Add to Personal Address Book" 
button. It dosen't add to Personal address book,either.

Comment 2

18 years ago
duplicate of one of these two bugs.  

http://bugzilla.mozilla.org/show_bug.cgi?id=18591
http://bugzilla.mozilla.org/show_bug.cgi?id=29436

Comment 3

18 years ago
This looks like a dup of 29436 but that's marked fixed and this is from a recent 
build.  Reassigning to rhp.
Assignee: putterman → rhp

Comment 4

18 years ago
I got about half of this done. The infrastructure is there in the 
mozilla/mailnews/addrbook/src directory, but I did it for the printing 
operations. The parsing and addition for "add" needs to be done to support the 
vcard feature.

- rhp
Assignee: rhp → chuang
Summary: Unable to add Vcard from 4.x to the Address Book → addbook: protocol handler needs to support add operation

Comment 5

18 years ago
moving to M17.
Target Milestone: --- → M17

Comment 6

18 years ago
Moving to M18 and nominating for beta3.
Keywords: nsbeta3
Target Milestone: M17 → M18

Comment 7

17 years ago
Actually this is more like a feature for address book.
Keywords: correctness

Comment 8

17 years ago
we either need to remove the Add To Address Book button or fix this feature.  
I'm leaning towards removing the button.

Updated

17 years ago
Keywords: mail1

Comment 9

17 years ago
marking - per mail triage.
We will remove the Add to Address book button on the vcard.  I will file a new
bug on that so that this particular bug to implement the feature can be looked
at a later time post release 1.
Whiteboard: [nsbeta3-]
Target Milestone: M18 → Future

Comment 10

17 years ago
removing the mail1 keyword
Keywords: mail1

Comment 11

17 years ago
Removing the mail1 keyword.

Comment 12

16 years ago
*** Bug 99386 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
reassigning to racham
Assignee: chuang → racham

Comment 14

15 years ago
I am managing an address book project (depending on LDAP) within Sun Microsystems
and I have several users using Mozilla/Netscape7 and would like to use this
feature. Is there any other possibility to add an entry to the browser's 
addressbook from an application?

TIA
    Detlef.Schmier@sun.com
mass re-assign.
Assignee: racham → sspitzer
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
Looks like we fixed this bug sometime in the past. "Add to Personal Address
Book" WFM, on linux build 20050412. Stephend, can verify on a windows build? thanks.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
This works fine in Seamonkey 2005-05-08-05 trunk builds on Windows XP.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.