Closing tabs incorrectly transfers the focus to old/other/previous tabs

RESOLVED WORKSFORME

Status

()

--
trivial
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: seandop, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME - 06/18)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Sometimes when closing a tab (i've only noticed it when clicking the x in the corner) the focus is not transfered to the previous tab.  I'll click the x, the tab will close, then I'll be left with a blank window.  The tabs still highlight on the MouseOver event, but any attempts to select a tab fail, with the exception of clicking the "List all tabs" button and selecting a tab from the list.  If you have only one tab however, then that button is not displayed (because the tabbar is not displayed).  Also, if you have only one tab open (without the focus), trying to browse to a URL in the address bar, opening new tabs, or opening bookmarks also fails.  This may cause loss of data because you cannot continue browsing or retrieve your information from the one open tab, no matter what you try.  If you are left with just the one tab and it does not contain the focus, your only choice is to close the window.

I had the Firefox Showcase Add-on installed at one time, and when this bug (closing a tab, and not receiving the focus) occurred, it would tell me that NO tabs were currently open.

Reproducible: Sometimes

Steps to Reproduce:
If you have a Facebook:
1. Open a new tab directly after this tab (adjacent to).
2. Browse to http://www.facebook.com and login.
3. Close the Tab with Facebook open in it.

Note, I'm trying to come up with a better example so that it can be universally reproducible, but this is all I have for now.
Actual Results:  
No tabs will have the focus, you will be staring at a blank window and cannnot continue your browsing session until you select a tap from the drop-down list provided by the "List all Tabs" button.

Expected Results:  
The focus should have been transfered to the previous tab.
This sounds like an extension/theme problem. Please retest in Firefox's safe-mode. If you can track down which extension is causing this, you can notify the author of the add-on.
If you still see problems in the -safe-mode you could try a re-install in a new empty folder or a new profile.

http://kb.mozillazine.org/Safe_Mode_(Firefox)
http://kb.mozillazine.org/Profile_Folder

Comment 2

12 years ago
WFM.  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/2007051502 Firefox/2.0.0.4

Reporter, do you have any feedback to comment #1?
Whiteboard: CLOSEME - 06/18
(Reporter)

Comment 3

12 years ago
I've since upgraded FF, gotten a new computer, reinstalled Windows, etc.  I no longer have this problem and am unable to reproduce it.  It may have been an extension problem at the time.  I'm resolving the bug to WORKSFORME.
Severity: critical → trivial
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.