closing the only browser window results in crash w/new profile

VERIFIED WORKSFORME

Status

Core Graveyard
Tracking
P3
critical
VERIFIED WORKSFORME
18 years ago
2 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: don)

Tracking

({crash, pp})

Trunk
PowerPC
Mac System 9.x
crash, pp

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
noticed this with today's opt comm bits on my 9.0 G3 [2000.04.21.10]:

1. start the browser, make sure only one window is present.
2. either click the close button, select File > Close, or Command+W

result: browser crashes.

talkback #9163311

0x00000004 
nsCOMPtr<8nsITimer>::~nsCOMPtr<8nsITimer>() 
nsDocShell::CancelRefreshURITimers() [nsDocShell.cpp, line 2032] 
nsDocShell::Stop() [nsDocShell.cpp, line 1076] 
nsDocShell::Stop() [nsDocShell.cpp, line 1097] 
nsDocShell::Destroy() [nsDocShell.cpp, line 1278] 
nsWebShell::Destroy() [nsWebShell.cpp, line 2029] 
nsXULWindow::Destroy() [nsXULWindow.cpp, line 411] 
nsWebShellWindow::Destroy() [nsWebShellWindow.cpp, line 1728] 
nsChromeTreeOwner::Destroy() [nsChromeTreeOwner.cpp, line 210] 
DOM_DLL + 0x1ac60 (0x05d1cac0) 
DOM_DLL + 0x20be0 (0x05d22a40) 
DOM_DLL + 0x89f8 (0x05d0a858) 
DOM_DLL + 0x7be0 (0x05d09a40) 
DOM_DLL + 0x60ff8 (0x05d62e58) 
nsEventListenerManager::HandleEventSubType() [nsEventListenerManager.cpp, line
703] 
nsEventListenerManager::HandleEvent() [nsEventListenerManager.cpp, line 1474] 
nsXULElement::HandleDOMEvent() [nsXULElement.cpp, line 3294] 
nsXULKeyListenerImpl::HandleEventUsingKeyset() [nsXULKeyListener.cpp, line 1590]
(Reporter)

Updated

18 years ago
Keywords: crash, pp, regression
(Reporter)

Updated

18 years ago
Blocks: 33178

Comment 1

18 years ago
I can't repro this. Does it matter what URL is being displayed? A page with meta-
refresh, perhaps?
(Reporter)

Comment 2

18 years ago
hm...i found this why using a relatively new profile (made w/today's build), so
the default page, rather than home.netscape.com, the one with What's New and the
swirling [animated] Netscape.

doublechecked with an existing profile, where my default homepage is something
else (www.mozilla.org/quality/) and this doesn't happen.

feel free to reassign/dup as needed. removing regression kw.
Keywords: regression
(Reporter)

Updated

18 years ago
No longer blocks: 33178
(Reporter)

Comment 3

18 years ago
updated summary.
Summary: closing the only browser window results in crash → closing the only browser window results in crash w/new profile
(Reporter)

Comment 4

18 years ago
*** Bug 37018 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
Marking "WORKSFORME" on Don's behalf.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

18 years ago
not seeing crashes recently
build 2000051208 ok
Status: RESOLVED → VERIFIED

Updated

14 years ago
OS: Mac System 9.x
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.