Sun Trust Personal Finance-bill Pay

VERIFIED DUPLICATE of bug 264594

Status

()

--
major
VERIFIED DUPLICATE of bug 264594
12 years ago
12 years ago

People

(Reporter: davenaylor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Sun trust has refused to use Mozilla for Bill pay . I can get into my accounts ,transfer funds etc. but can't  pay bills. I am out of the country allot so this is a problem. I am forced to use  IE which is totally messed up....can't even got onto the Sun Trust site with IE. Have been on Sun Trust butt about this for years...they say they are taking it under advisement...... it"s getting to be a huge problem.

Reproducible: Always

Steps to Reproduce:
1.sign into a Sun trust personal Finance account ( not giving you MY numbers)
2.go to bill pay and you get a list of recommended browsers...Mozilla is not listed
3.am forced to use someone on the list...
Actual Results:  
forced to go to IE

Expected Results:  
at IE, with Sun trust's help, I am no longer able to get to my accounts using IE...As I am in Italy trying to get thing sorted out it's getting to be a mayor pain. ans no-one will explain about the non use of Mozilla.
(Reporter)

Comment 1

12 years ago
I complained about this a few years ago to Sun Trust.... Sun trust replied to the affect that there  were too many Mozilla builds.....I keep sending them articles etc about safety issues (Mozilla vs. Internet Explorer) but with the exception of that one response a few years ago they just ignore me. I have threatened to take my accounts to a bank that uses Mozilla.. will start looking into it when i return to the states.
thanks ..............
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 264594

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.