Mingw build error in gfxWindowsFonts.cpp

RESOLVED DUPLICATE of bug 371659

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 371659
12 years ago
11 years ago

People

(Reporter: Bengt-Erik Soderstrom, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 obsolete attachments)

(Reporter)

Description

12 years ago
Again a Mingw build error: gfxWindowsFonts.cpp

A couple of days ago it was OK but now I get this:

Building deps for /cygdrive/d/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp

/cygdrive/d/mozilla/mozilla/build/cygwin-wrapper g++ -mno-cygwin -o gfxWindowsFo
nts.o -c  -DIMPL_THEBES -DMOZILLA_INTERNAL_API -DOSTYPE=\"WINNT5.1\" -DOSARCH=\"
WINNT\" -DBUILD_ID=2007012213  -I../../../dist/include/cairo -I../../../dist/inc
lude/libpixman -I../../../dist/include/string -I../../../dist/include/pref -I../
../../dist/include/xpcom -I../../../dist/include/unicharutil -I../../../dist/inc
lude/gfx -I../../../dist/include   -I../../../dist/include/thebes -I../../../dis
t/include/nspr  -DMOZ_PNG_READ -DPNG_NO_MMX_CODE -DMOZ_PNG_WRITE  -I../../../dis
t/sdk/include       -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith
 -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtu
al-dtor -Wno-long-long -pedantic -mms-bitfields -pipe  -DNDEBUG -DTRIMMED -O -I.
./../../dist/include/cairo    -DWINVER=0x501 -D_WIN32_WINNT=0x501 -D_WIN32_IE=0x
0400 -DX_DISPLAY_MISSING=1 -DMOZILLA_VERSION=\"1.9a2pre\" -DMOZILLA_VERSION_U=1.
9a2pre -DHAVE_SNPRINTF=1 -D_WINDOWS=1 -D_WIN32=1 -DWIN32=1 -DXP_WIN=1 -DXP_WIN32
=1 -DHW_THREADS=1 -DSTDC_HEADERS=1 -DWIN32_LEAN_AND_MEAN=1 -DNO_X11=1 -D_X86_=1
-DD_INO=d_ino -DSTDC_HEADERS=1 -DHAVE_DIRENT_H=1 -DHAVE_GETOPT_H=1 -DHAVE_MEMORY
_H=1 -DHAVE_UNISTD_H=1 -DHAVE_MALLOC_H=1 -DHAVE_LIBM=1 -DNO_X11=1 -DMMAP_MISSES_
WRITES=1 -DHAVE_STRERROR=1 -DHAVE_SNPRINTF=1 -DHAVE_MEMMOVE=1 -DHAVE_RINT=1 -DVA
_COPY=va_copy -DHAVE_VA_COPY=1 -DMOZ_EMBEDDING_LEVEL_DEFAULT=1 -DMOZ_EMBEDDING_L
EVEL_BASIC=1 -DMOZ_EMBEDDING_LEVEL_MINIMAL=1 -DMOZ_PHOENIX=1 -DMOZ_BUILD_APP=bro
wser -DMOZ_XUL_APP=1 -DMOZ_DEFAULT_TOOLKIT=\"cairo-windows\" -DMOZ_THEBES=1 -DMO
Z_CAIRO_GFX=1 -DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DOJI=1 -DIBMBIDI=1 -DMOZ_VI
EW_SOURCE=1 -DMOZ_XPINSTALL=1 -DMOZ_JSLOADER=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIE
W=1 -DMOZ_NO_XPCOM_OBSOLETE=1 -DMOZ_XTF=1 -DMOZ_MATHML=1 -DMOZ_ENABLE_CANVAS=1 -
DMOZ_SVG=1 -DMOZ_SVG_FOREIGNOBJECT=1 -DMOZ_UPDATE_CHANNEL=default -DMOZ_PLACES=1
 -DMOZ_FEEDS=1 -DMOZ_STORAGE=1 -DMOZ_SAFE_BROWSING=1 -DMOZ_URL_CLASSIFIER=1 -DMO
Z_LOGGING=1 -DHAVE___CXA_DEMANGLE=1 -DMOZ_USER_DIR=\"Mozilla\" -DHAVE_STDINT_H=1
 -DHAVE_INTTYPES_H=1 -DHAVE_UINT64_T=1 -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DMOZ_
RDF=1 -DMOZ_MORKREADER=1 -DMOZ_DLL_SUFFIX=\".dll\" -DJS_THREADSAFE=1 -DMOZILLA_L
OCALE_VERSION=\"1.9a1\" -DMOZILLA_REGION_VERSION=\"1.9a1\" -DMOZILLA_SKIN_VERSIO
N=\"1.8\"  -UWIN32_LEAN_AND_MEAN -D_MOZILLA_CONFIG_H_ -DMOZILLA_CLIENT /cygdrive
/d/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp: In member function `HFONT
__* gfxWindowsFont::MakeHFONT()':
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:226: warning: comparison b
etween signed and unsigned integer expressions
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp: In member function `virtu
al nsString gfxWindowsFont::GetUniqueName()':
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:443: error: call of overlo
aded `AppendInt(LONG&)' is ambiguous
../../../dist/include/string/nsTString.h:392: note: candidates are: void nsStrin
g::AppendInt(PRInt32, PRInt32)
../../../dist/include/string/nsTString.h:398: note:                 void nsStrin
g::AppendInt(PRUint32, PRInt32)
../../../dist/include/string/nsTString.h:407: note:                 void nsStrin
g::AppendInt(PRInt64, PRInt32)
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp: In member function `doubl
e gfxWindowsTextRun::MeasureOrDrawFast(gfxContext*, PRBool, gfxPoint)':
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:848: warning: comparison b
etween signed and unsigned integer expressions
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp: In constructor `Uniscribe
Item::UniscribeItem(gfxContext*, HDC__*, const PRUnichar*, PRUint32, SCRIPT_ITEM
*, gfxWindowsFontGroup*)':
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:1498: warning: `UniscribeI
tem::mAlternativeString' will be initialized after
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:1492: warning:   `SCRIPT_I
TEM*UniscribeItem::mScriptItem'
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:1021: warning:   when init
ialized here
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:1507: warning: `UniscribeI
tem::mNumGlyphs' will be initialized after
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:1506: warning:   `int Unis
cribeItem::mMaxGlyphs'
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:1021: warning:   when init
ialized here
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp: In member function `cairo
_glyph_t* UniscribeItem::GetCairoGlyphs(const gfxPoint&, gfxFloat&, PRUint32*)':

d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:1267: warning: comparison
between signed and unsigned integer expressions
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp: In member function `doubl
e gfxWindowsTextRun::MeasureOrDrawUniscribe(gfxContext*, PRBool, gfxPoint)':
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:1632: warning: unused vari
able 'fontIndex'
../../../dist/include/thebes/gfxWindowsFonts.h: At global scope:
../../../dist/include/thebes/gfxWindowsFonts.h:232: warning: 'PRUint8 CharRangeB
it(PRUint32)' defined but not used
make[6]: *** [gfxWindowsFonts.o] Error 1
make[6]: Leaving directory `/cygdrive/d/mozilla/mozilla/object-mingw/gfx/thebes/
src'
make[5]: *** [libs] Error 2
make[5]: Leaving directory `/cygdrive/d/mozilla/mozilla/object-mingw/gfx/thebes'

make[4]: *** [libs] Error 2
make[4]: Leaving directory `/cygdrive/d/mozilla/mozilla/object-mingw/gfx'
make[3]: *** [libs_tier_gecko] Error 2
make[3]: Leaving directory `/cygdrive/d/mozilla/mozilla/object-mingw'
make[2]: *** [tier_gecko] Error 2
make[2]: Leaving directory `/cygdrive/d/mozilla/mozilla/object-mingw'
make[1]: *** [alldep] Error 2
make[1]: Leaving directory `/cygdrive/d/mozilla/mozilla/object-mingw'
make: *** [alldep] Error 2
Component: Build Config → GFX: Thebes
Product: Firefox → Core
QA Contact: build.config → thebes

Comment 1

12 years ago
I was able to build the trunk using mingw without issue using a cvs pull after this bug was filed. What are you building, trunk? What is your .mozconfig? Are you using VC8 Express?
I'm getting this build error too. I build using gcc.
This is a regression from bug 366870.
Blocks: 366870
Created attachment 252405 [details] [diff] [review]
patch

This fixes it for me.
Attachment #252405 - Flags: review?(vladimir)
Can't you just cast to PRInt32() ?
(Reporter)

Comment 5

12 years ago
(In reply to comment #3)
> Created an attachment (id=252405) [details]
> patch
> 
> This fixes it for me.
> 

Thanks, Martijn. Your patch seems to work fine.
Unfortunately there are more Mingw build errors, I filed bug 367860 today

(Reporter)

Comment 6

12 years ago
(In reply to comment #1)
> I was able to build the trunk using mingw without issue using a cvs pull after
> this bug was filed. What are you building, trunk? What is your .mozconfig? Are
> you using VC8 Express?
> 

For your information, and others, this is my mingw .mozconfig which has been working just fine for the past months.


. $topsrcdir/browser/config/mozconfig
#mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/object
# Alternatives for MinGW
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/object-mingw
CC=gcc
CXX=g++
CPP=cpp
AS=as
LD=ld
ac_add_options --enable-optimize
ac_add_options --enable-crypto
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --disable-accessibility
ac_add_options --disable-activex
ac_add_options --disable-activex-scripting
ac_add_options --disable-xpconnect-idispatch
ac_add_options --disable-libxul
ac_add_options --disable-installer
ac_add_options --enable-svg
ac_add_options --enable-canvas
ac_add_options --enable-default-toolkit=cairo-windows
Created attachment 252455 [details] [diff] [review]
patch

You mean like this?
Attachment #252455 - Flags: review?(vladimir)
(Reporter)

Comment 8

12 years ago
(In reply to comment #7)
> Created an attachment (id=252455) [details]
> patch
> 
> You mean like this?
> 

Maybe cast is a bit more elegant. Anyhow it works for me.

Updated

12 years ago
Blocks: 203303
Attachment #252405 - Attachment is obsolete: true
Attachment #252405 - Flags: review?(vladimir)
Vlad, could you review the tiny little patch?
Duplicate of this bug: 373186

Comment 11

11 years ago
Comment on attachment 252455 [details] [diff] [review]
patch

Fixed on 2007-02-27 in rev 1.86 of gfxWindowsFonts.cpp by mats.palmgren - not sure if there ended up being a separate bug, no bug # was referenced in the checkin
Attachment #252455 - Attachment is obsolete: true
Attachment #252455 - Flags: review?(vladimir)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Thanks, it was bug 371659.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 371659
You need to log in before you can comment on or make changes to this bug.