100% CPU consumption in jpeg_free_large

RESOLVED DUPLICATE of bug 365653

Status

()

--
critical
RESOLVED DUPLICATE of bug 365653
12 years ago
12 years ago

People

(Reporter: pavelgutsa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Just 

Reproducible: Sometimes

Steps to Reproduce:
To reproduce you have to leave FF open for some time, happens for me if I leave it open overnight.
This thread occupies 100% CPU.  It doesn't make FF unresponsive, but does make it very slow.
I'll attach 2 snapshots of the thread stacks, normal and consuming.
(Reporter)

Comment 1

12 years ago
Created attachment 252378 [details]
Normal operation

This is how the stack looks like normally.  You can see that this is the most CPU consuming threads in FF by context switch delta
(Reporter)

Comment 2

12 years ago
Created attachment 252379 [details]
This is when it goes wrong

CPU is 50% because machine has 2 of them...
I think this is a duplicate of Bug 365653. Please reopen if it is basically different. Maybe you could attach your screenshot there?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 365653
You need to log in before you can comment on or make changes to this bug.