Websites draw in to anonymous X window

RESOLVED DUPLICATE of bug 263160

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 263160
11 years ago
10 years ago

People

(Reporter: Nick Stallman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20070120 SeaMonkey/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20070120 SeaMonkey/1.0.7

Occasionally Seamonkey opens a X window and draws on to it instead of where the page should go.
Tabs and other UI elements arent drawn there and work fine.

If you hit the close button on the X window then Seamonkey crashes.
However closing the window's tab closes the X window and everything keeps functioning happily.

It occurs sporatically. I cant reproduce it on demand.
Only happens after at least ~6 hours of Seamonkey being open. Sometimes it only happens after weeks.

It may be caused by me using Ctrl-Alt-Fx to switch to a real console and Alt-F7 to get back in to X.
E.g. The Google personalised home page in the screenshot refreshes occasionally. The screenshotted one was done when I was looking at a real console.
Not all the time is it caused by that however.

Reproducible: Sometimes

Steps to Reproduce:
1. Switch away from X
2. Page reloads while X isnt focussed or sometime afterwards switching
Actual Results:  
Seamonkey started drawing pages to the wrong place

Expected Results:  
It should have drawn to the middle of the Seamonkey window

Comment 1

11 years ago
xprop (?) output would be nice.

it's probably a popup that asked for no decorations.
Whiteboard: DUPEME
(Reporter)

Comment 2

11 years ago
Nah this is definately not normal. It spews errors out on the console.
I couldnt grab them before they went off screen.
They were Gecko, GTK, DCOM (may or may not be related) and X errors.

The start of a few errors was '(gecko:25360)'.

I'll get you xprop when it happens again along with the errors.
(Reporter)

Comment 3

11 years ago
xprop of the window its drawing to:

_NET_WM_ICON_GEOMETRY(CARDINAL) = 1582, 722, 142, 23
WM_STATE(WM_STATE):
                window state: Normal
                icon window: 0x0
_NET_WM_ALLOWED_ACTIONS(ATOM) = _NET_WM_ACTION_MOVE, _NET_WM_ACTION_RESIZE, _NET_WM_ACTION_MINIMIZE, _NET_WM_ACTION_SHADE, _NET_WM_ACTION_MAXIMIZE_VERT, _NET_WM_ACTION_MAXIMIZE_HORZ, _NET_WM_ACTION_FULLSCREEN, _NET_WM_ACTION_CHANGE_DESKTOP, _NET_WM_ACTION_CLOSE
_NET_WM_STATE(ATOM) =
_KDE_NET_WM_FRAME_STRUT(CARDINAL) = 4, 4, 27, 4
_NET_FRAME_EXTENTS(CARDINAL) = 4, 4, 27, 4
_NET_WM_DESKTOP(CARDINAL) = 0
_KDE_NET_WM_USER_CREATION_TIME(CARDINAL) = 1366782131


I'll attatch xprop of the main Seamonkey window.

As you can see something is seriously wrong.
(Reporter)

Comment 4

11 years ago
Created attachment 252534 [details]
xprop output from the main Seamonkey window while there is a glitched window
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 263160
You need to log in before you can comment on or make changes to this bug.