If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

memory leak in browser/safebrowsing/sb-loader.js?

RESOLVED INVALID

Status

()

Toolkit
Safe Browsing
RESOLVED INVALID
11 years ago
3 years ago

People

(Reporter: peter gervai, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061205 Iceweasel/2.0.0.1 (Debian-2.0.0.1+dfsg-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061205 Iceweasel/2.0.0.1 (Debian-2.0.0.1+dfsg-1)

[I tried to look up this bug, but either got zero or many hundreds of results, please apply your human experience driven duplicate finder. :-) In other words, if you feel this is a duplicate, feel free to close.]

On startup I got a warning from "leak monitor 0.3.6" addon that there were objects leaked when restoring the session. As far as my limited code knowledge goes, it was at line 53-56 in sb-loader.js.

One was onDocNavStart and a leaked function, and other were a request object with lots of requests (83 in this case), probably the amount of opened tabs in that window. 

Haven't seen it since, so it might have been triggered by coincidences in network speed, my clicking on the bazillions of popups and the phase of the moon. If that's too random for you, close at will. 

Thanks.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch
(Reporter)

Comment 1

11 years ago
(Yes, it's Debian; no this component was not changed in Debian; yes, it extremely probably behaves the same in stock firefox; yes, thanks for understanding.)
(Reporter)

Comment 2

9 years ago
Okay then closing. ;)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Assignee)

Updated

3 years ago
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.