Transparent window style (background-color: transprent;) not effective on Mac Os X 10.4

VERIFIED DUPLICATE of bug 307204

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 307204
11 years ago
10 years ago

People

(Reporter: guillaume.gauthier, Unassigned)

Tracking

1.5.0.x Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; fr; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; fr; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

The following xul code used in xulrunner with Windows XP shows only the description text on top of the screen (the window itself is as expected transparent). On Mac Os X 10.4 using the same release of xulrunner 1.8.0.4 it shows the same text but inside a white window instead of transparent one...

<window id="Transp-Window" 
	xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
	title="Transparent window"
	sizemode="maximized"
	style="background-color: transparent;">
	<hbox>
		<spacer flex="1"/>
		<description class="opaque">Transparent ?</description>
		<spacer flex="1"/>
	</hbox>
</window>

Reproducible: Always

Steps to Reproduce:
1.Install xulrunner 1.8.0.4 on Mac Os X
2.Copy the previous source code into a xul application structure transp.xulapp/chrome/content/xxx.xul
3.build your application /Library/Frameworks/XUL.framework/xulrunner-bin --install-app xxx
4.Double click on the app icon generated in the mac application folder
Actual Results:  
White window

Expected Results:  
Transparent window (as seen in Windows Xp)
(Reporter)

Updated

11 years ago
Version: unspecified → 1.5.0.x Branch

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 307204
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.