Hang after launch app on Linux. might be related to dir path problem.

VERIFIED WORKSFORME

Status

Core Graveyard
Installer: XPInstall Engine
P3
critical
VERIFIED WORKSFORME
18 years ago
2 years ago

People

(Reporter: David Epstein, Assigned: Cathleen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Linux only. afternoon build. 2000-04-21-13-M16.
1. Download stub installer: mozilla-i686-pc-linux-gnu-installer.tar.
2. gzip it. Then tar extract (tar -xvf).
3. Run installer. In Installer wizard, enter another directory to install to.
4. Finish wizard install.
5. Check console window.
Results: Get msg: "Load FAILED with error: <unknown; can't get error from NSPR.
It's hanging at "WEBSHELL+ = 1". A couple of "JS Component Loader" warnings.
Note directory problem: If you check in /chrome subdirectories, we have a folder 
called "conten" (truncated) with a *nested* folder "content". It should just be 
"content".
Examples: /chrome/communicator/conten/content/*.
Expected: /chrome/communicator/content/*
Try also /chrome/editor, /chrome/global, /chrome/messenger, /chrome/navigator.
I did change these to ../content, then relaunched app, but it still hanged. Will 
investigate further with unzipped xpis. We'll see if there's a packaging issue.
(Assignee)

Comment 1

18 years ago
folder "content" is getting truncated as "conten" on linux during install

I checked the packager file, and didn't see anything that would cause this 
problem to happen under every subdir in chrome

Is this something caused by nsIFiles changes?

Comment 2

18 years ago
Yes, this first showed up on dbragg's nsIFile branch.  I thought it went away as 
of yesterday?  

Cathleen, what build did you use?  

David, I think we had concluded we should mark this wroksforme.  Please concur 
or justify against.  Thanks.
(Assignee)

Comment 3

18 years ago
marking WORKSFORME for now.
Dave, can you help verify with today's build?
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 4

18 years ago
David,
You probably won't be able to verify this with today's build since the installer 
is broken due to a different reason (bug 37086).  I might have a fix for this so 
hopefully you'll be able to verify this in tomorrow's builds.
(Reporter)

Comment 5

18 years ago
Yes, the Linux installer konked out on me.

Comment 6

18 years ago
Reassigning QA Contact to David.
QA Contact: jimmylee → depstein
(Reporter)

Comment 7

18 years ago
Not happening anymore. Linux build 2000-05-09-08-M16.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.