New windows display off screen when using Dual Mointor with different resolution

RESOLVED DUPLICATE of bug 394843

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 394843
11 years ago
9 years ago

People

(Reporter: I. Lam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

When Firefox create a new window on a dual screen monitor with different resolution, the position is off screen. 

Reproducible: Always

Steps to Reproduce:
1.Suppose you have a dual screen monitor A and B. Monitor A is 1600x1200, Monitor B is 800x600 (exact resolution doesn't matter, as long as one is big, the other is  small).
2.Open up Mozilla on Mointor A (1600x1200), resize the windows to 700x800 on mointor A (exact number doesn't matter as long as the window fit monitor A but slightly longer on Monitor B).
3. Move the Mozilla window from Monitor A (1600x1200) to Monitor B (800x600).
4. Now, open a new mozilla window by pressing "Ctrl-N". 
Actual Results:  
The new window title bar will dispaly offscreen. There is no way to use the mouse to drag the windows back to visible location. 

Expected Results:  
The new window should display within the Monitor B (800x600), with length small than 600 pixel. Or at least, the title bar of the new Mozilla window should position within the screen limit, not above the visible screen.

From then, every time you open a new firefox windows, it will display offscreen with no way to reposition. This problem may also occur with a single monitor setup when the user switch from high resolution to low resolution (althought this has not been verified)

The problem doesn't happen on IE or other windows applications.

The new window size should be calculated with the monitor resolution it displayed in, not using the actual size of the current Firefox windows (since the current firefox windows can be larger than the current monitor resolution)

Comment 1

11 years ago
Can be related, sorry if not, but dual screen problem.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

I have 3 monitors, all with the same resolution. The middle monitor is the default one with he windows toolbar on the bottom (kind of tall, 2 rows for open windows display and a third row for Quick Launch).

Reproducible: Always

Steps to reproduce:

1. Open FF in not maximized state. 
2. Move it to a screen without the Windows Toolbar. 
3. Resize the browser window to fit on the full screen.
4. Close FF.
5. Reopen it.

Actual result: the width is preserved, but height is cropped on the bottom, exactly to leaving space for the non-existent Windows Toolbar on that screen.

Expected result: Browser window should not automatically resize itself to leave space for windows toolbar on a secondary screen with no Windows Toolbar.

Comment 2

11 years ago
interesting, i don't see comment 0 or comment 1. 
Vista, Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5

Monitor A 1680x1050
Monitor B 1280x1024

Comment 3

11 years ago
I've reproduced this bug (didn't try to reproduce comment #1) on Mac OS X 10.3.9 with Firefox 2.0.0.6

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

I have verified that this bug is NOT in SeaMonkey 1.1.4 or in Camino 1.5.1 (I couldn't get the Firefox/Minefield nightly build to run on my Mac to test it.)

Some additional information that *might* help reproduce the bug: I have my smaller monitor positioned below and to the left of my main, larger monitor. 

This is similar to a few other bugs I found:

Bug 251024
Bug 323469 
Bug 354187

It might have been influenced by work relating to Bug 218214 although that's a Mac-only bug and this one is cross-platform.  

Comment 4

11 years ago
(In reply to comment #2)
> interesting, i don't see comment 0 or comment 1. 
> Vista, Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.5)
> Gecko/20070713 Firefox/2.0.0.5
> 
> Monitor A 1680x1050
> Monitor B 1280x1024
> 

Well, your monitor B height is only 26 pixels less than your monitor A height, and it appears that Firefox is trying to center the window vertically, so if your window title bar is more than 13 pixels high you might not really be affected by this bug.

Comment 5

11 years ago
I don't know what I did wrong before, but I've now reproduced this bug in SeaMonkey 1.1.4 and last nights SeaMonkey build:

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.7pre) Gecko/20070903 SeaMonkey/1.1.5pre

I'm opening a bug on Core/Widget...

Comment 6

11 years ago
Opened Bug 394843 on Core/Widget because I couldn't change the product and component of this bug.

Comment 7

11 years ago
See further details at Bug 394843

Comment 8

9 years ago
According to comment #6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 394843
You need to log in before you can comment on or make changes to this bug.