tabbox bindings don't care about disabled tabs

RESOLVED DUPLICATE of bug 106387

Status

()

Core
XUL
--
major
RESOLVED DUPLICATE of bug 106387
12 years ago
10 years ago

People

(Reporter: WeirdAl, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
The current implementation of advanceSelectedTab ignores the possibility of disabled tab elements.
(Reporter)

Comment 1

12 years ago
The problem is bigger than I thought.  Basically, the word "disabled" appears only twice in the entire tabbox.xml file, and then only for xbl:inherits attributes.  None of the bindings do any checking to see if a tab is disabled.
Severity: normal → major
Summary: tabs.advanceSelectedTab ignores disabled tabs → tabbox bindings don't care about disabled tabs
(Reporter)

Comment 2

12 years ago
whoops; the bug was filed in Toolkit, and I looked in Core.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 106387

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.