compreg.dat and xpi.dat files slow to write on network drives

RESOLVED WORKSFORME

Status

()

Core
XPCOM
--
major
RESOLVED WORKSFORME
11 years ago
2 years ago

People

(Reporter: Steve, Unassigned)

Tracking

({perf})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.9

The compreg.dat and xpti.dat files are created the first time you run firefox when your profile is created, or are recreated after you update firefox or install an extension. On Windows, using folder redirection, the %appdata% folder is put on a network server, so the users firefox profile is on the server. Firefox is writing the compreg.dat and xpti.dat files one line at a time for a total of over 3000 writes. The total size of the files is only a couple hundred KB. This high number of small size writes over a network connection can be VERY taxing. Why cant Firefox pre-create the files in memory, and write them to the file system with one write command? This should improve the general startup speed of firefox, no matter where its writing the files.

The affects us because we use roaming profiles in Windows. Roaming profiles means that the users entire Windows profile will move with them from computer to computer, this Windows profile contains the users firefox profile too. When firefox is installed, it writes the time stamps of certain files in the firefox program directory, into the compreg.dat and xpti.dat files. With firefox being installed onto 1000 computers at different times, the time stamps on the files will be different. Since the compreg.dat and xpti.dat files are stored in the users profile, the time stamps contained in them will never match whats on each computer. So this means the compreg.dat and xpti.dat files get recreated every time the user starts firefox. In our environment, depending on network and server performance, this can cause a 3 to 30 second delay in the startup of firefox. Even longer the first time someone runs firefox, because it seems to create the files twice.


Reproducible: Always

Steps to Reproduce:
1. Delete the compreg.dat and xpti.dat files from the firefox user profile directory.
2. Using FileMon, run firefox, watch the firefox.exe process and you will see it writing to the compreg.dat and xpti.dat files several thousand times.



This affects Thunderbird too.

Tested with:
Windows XP SP2 (client)
Windows Server 2003 R2 (server)
Firefox 1.5.0.9
Firefox 2.0.0.1
Thunderbird 1.5.0.9

Updated

11 years ago
Status: UNCONFIRMED → NEW
Component: Startup and Profile System → XPCOM
Ever confirmed: true
Product: Firefox → Core
QA Contact: startup → xpcom
Version: unspecified → Trunk

Comment 1

9 years ago
Please note Bug 157662 -- FF embeds absolute file paths inside its profile data basically unusable as it destabilizes the FF profile depending on the redirection mode.

Updated

8 years ago
Keywords: perf

Comment 2

8 years ago
Firefox now puts compreg/xpti in the Local profile directory, not the Roaming directory, so unless your roaming profile is configured oddly this is no longer an issue.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

8 years ago
I assume you are testing FF v3.6. If thats the case, I just double checked, and I dont see any change in the storage location of the compreg/xpti.dat files. FF still asks Windows for the AppData environment variable to find the profile directory, which can be redirected to a network share. The AppData environment variable comes from this registry location: "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\AppData"

This has been tested with FF v3.6 on Windows XP and 7.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 4

2 years ago
both files are gone per bug 72518 and bug 570488
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.