URL Not Accepting Inupt

RESOLVED WORKSFORME

Status

Camino Graveyard
Location Bar & Autocomplete
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Philip Gaitan, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.2pre) Gecko/20070124 Camino/1.1a2+
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.2pre) Gecko/20070124 Camino/1.1a2+

Opened Camino and it loaded the "home" page with out issue.  Changed focus to another program to copy a URL to the clip board then changed focus back to Camino.  The location bar would not accept any text or cursor input (i.e. hilighting the current URL) nor would it allow me to past the URL on the clipboard.

Reproducible: Sometimes

Steps to Reproduce:
1. Open Camino
2. Change focus to another program
3. Change back to Camino and try to manipulate the location bar in any way
Actual Results:  
I can't get it to happen each and every time, however several times the location bar seemed to be 'frozen'.  The Google search bar allowed input, the location bar did not.

Expected Results:  
The location bar should always allow keyboard and mouse manipulation.

Comment 1

11 years ago
Do you have *any* third-party input managers installed on the system?

Does a fresh profile change anything? Try

http://pimpmycamino.com/parts/troubleshoot-camino

and see what happens.

cl
(Reporter)

Comment 2

11 years ago
Chris, thank you for that.  I must have failed to read that somewhere before submitting a bug report.  I can't get it to fail out in the location bar while using a fresh profile.  I've exported my bookmarks and will make it habitual from here on to start with a new profile on each nightly build.

And no, there were no third party input managers.

Thanks again!
Phil
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 3

11 years ago
You definitely shouldn't have to use a new profile with each new build; that's just a debugging step. If it happens with your usual profile but not a clean profile, we'd like to try to narrow it down to what in your profile is triggering the bug.

Could you try to narrow it down to a specific file in your profile? Trying with a fresh user.js/prefs.js in your existing profile would be a good first step (although be sure to keep your user.js/prefs.js somewhere so you can restore them later).
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Phil, did you still have your old profile?  If so, have you had a chance to to try to narrow down the offending file or pref in that profile as Stuart suggested above?
Closing WFM due to lack of updates.  If you still have the old profile around to do some debugging, you may reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.