The system fonts are not rendered in same size as other applications

RESOLVED WONTFIX

Status

()

Core
Graphics
RESOLVED WONTFIX
11 years ago
2 years ago

People

(Reporter: masayuki, Assigned: masayuki)

Tracking

({intl})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

See the screenshot.
http://bugzilla.mozilla.gr.jp/attachment.cgi?id=3457

The system setting for the menu is "Tahoma 8pt". But Tahoma doesn't have Japanese characters.

# Therefore, the Japanese font should be selected by FontLink.
# But we don't implement the FontLink, see bug 362093. It will be fixed.

Now, we use same font size for Tahoma and Japanese fonts. But the Win32API doesn't so. It changes the font size at rendering the Japanese font. We (bugzilla-jp testers) tested this issue. We confirmed the following things:

1. only at 8pt or 10pt, the Japanese fonts are not changed the size.
2. we cannot see the same behavior on the HTML contents of WinIE7.

And I found the bug 84668, I read the comments of this bug. I think that the bug is same as this bug. Therefore, I guess that this bug is reproduced on CJKT. We should remove the patch of bug 84668 from thebes (there is a same code). Because it changes the size of Tahoma, it's not good. And we should change the font size if the linked font has CJK characters.
> 1. only at 8pt or 10pt, the Japanese fonts are not changed the size.
1. only at 8pt or 10pt, the Japanese fonts *are* changed the size.

I found this issue in the blog of web design.
http://hail2u.net/blog/webdesign/11px_sized_text.html
-> WONTFIX due to bug 362093 was marked as WONTFIX
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.