when parser fails dialog with information is not displayed properly

RESOLVED WONTFIX

Status

--
major
RESOLVED WONTFIX
12 years ago
9 years ago

People

(Reporter: damian.publicemail, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20070125 Calendar/0.3.1pre

I installed polish langpack to have Polish look&feel but this extension was not compatible so parser failed. The problem is that dialog was resized to very small area so user can not see it

Reproducible: Always

Steps to Reproduce:
1. Install extension which causes parser error (I use langpack)
2. Run Sunbird (sunbird.exe -uiLocale pl)

Actual Results:  
Sunbird does not start but the very small dialog wihout title is displayed (see attachment). You need to resize it to see what's going on.

Expected Results:  
User need to see information that parsing failed and Sunbird should start even there are some errors
(Reporter)

Comment 1

12 years ago
Created attachment 252812 [details]
screenshot, result
(Reporter)

Comment 2

12 years ago
Created attachment 252815 [details]
extension (langpack) that causes the problem

let me attach the extenstion so everyone can reproduce it and easily verify resolution. minVersion has been updated so this is compatible with  sunbird-0.3.1pre
(Reporter)

Updated

12 years ago
Flags: blocking-calendar0.5?
To understand it correct: You take an extension that clearly says it's not compatible with versions below 0.4a1, force it to install into 0.3.1pre and wonder why it's fail?

I'm sure the resulting entity error is known for all Mozilla products for ages. The window not being resizable is just an OS issue, e.g. on Linux you can resize the window and see the error message. I'm sure the error is also shown in console.

Try a language pack targeted for your Sunbird version and if the problem still exist the corresponding localization needs to be updated. Language builds for 0.3.1pre are available at http://wiki.mozilla.org/User:Nightrat
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> To understand it correct: You take an extension that clearly says it's not
> compatible with versions below 0.4a1, force it to install into 0.3.1pre and
> wonder why it's fail?
Almost, I've updated minVersion in extension so it is compatible - other else you can not run it


> I'm sure the resulting entity error is known for all Mozilla products for ages.
> The window not being resizable is just an OS issue, e.g. on Linux you can
> resize the window and see the error message.
No, on Windows I can resize too. The problem is that it must be resized before it is displayed so information is visible.
Firefox has it implemented properly - at first you can see error at second firefox starts

> Try a language pack targeted for your Sunbird version and if the problem still
> exist the corresponding localization needs to be updated.
It is not the resolution. Sunbird can not fails because someone did mistake in extension.
This won't block 0.5.
Flags: blocking-calendar0.5? → blocking-calendar0.5-

Updated

11 years ago
Flags: blocking-calendar0.5-
Language pack extensions are special. They modify the whole entity file. If the langpack doesn't define an entity that is needed in the main window, then the entity error will appear. I can't imagine this is not happening for firefox.

If you want, please test:

* get any firefox langpack.
* Open the xpi, open the locale jar file
* Remove some <!ENTITY ...> used from the main window
* Save the files back to the xpi
* Start firefox.

Result: The yellow error window should open at its last size. If this was smaller then, you might not see the message. There's not much we can do about this.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.