Last Comment Bug 368235 - l10n hg account for Kim Ludvigsen (da)
: l10n hg account for Kim Ludvigsen (da)
Status: RESOLVED FIXED
ssh-key, voucher, [allhands]
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Dave Miller [:justdave] (justdave@bugzilla.org)
:
:
Mentors:
Depends on: 370168
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-25 14:46 PST by Kim Ludvigsen
Modified: 2011-09-13 14:55 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Public SSH key (1.10 KB, text/plain)
2007-02-12 03:38 PST, Kim Ludvigsen
no flags Details
New public key (598 bytes, text/plain)
2011-07-26 10:26 PDT, Kim Ludvigsen
no flags Details

Description Kim Ludvigsen 2007-01-25 14:46:29 PST
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; da; rv:1.8.1.1) Gecko/20061223 PmWFx/2.0.0.1
Build Identifier: 

I'm translating Sunbird/Lightning to danish and need CVS write access to upload my translations.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Marcia Knous [:marcia - use ni] 2007-01-26 11:50:09 PST
Need the following to get the process started:

(1) CVS Form (www.mozilla.org/hacking/form.html
(2) Someone to vouch who already has access
(3) For write access, 3 super reviewers to post in the bug
(4) SSH key attached to the bug.
Comment 2 Kim Ludvigsen 2007-02-12 03:38:41 PST
Created attachment 254797 [details]
Public SSH key

Public SSH key attached, CVS form is send by mail.
Comment 3 Søren Munk Skrøder (extended hiatus) 2007-02-12 05:01:49 PST
Vouching for Kim ;-)
Comment 4 Søren Munk Skrøder (extended hiatus) 2007-02-16 15:11:39 PST
Marcia : 

Concerning item #3 in you list 
<< (3) For write access, 3 super reviewers to post in the bug >>

Does that also apply for people who only wish write access to the /l10n tree ? (i see the point with regards to /cvsroot, but not /l10n )
Comment 5 Marcia Knous [:marcia - use ni] 2007-02-16 15:34:44 PST
No, he doesn't need SR for this, but Axel usually reviews the CVS application requests and then gives me approval when he feels it is ready to go.

(In reply to comment #4)
> Marcia : 
> 
> Concerning item #3 in you list 
> << (3) For write access, 3 super reviewers to post in the bug >>
> 
> Does that also apply for people who only wish write access to the /l10n tree ?
> (i see the point with regards to /cvsroot, but not /l10n )
> 

Comment 6 Kim Ludvigsen 2007-02-23 10:52:30 PST
Marcia:

Have you received the CVS form? Even though it is send by snail mail, it should not take this long.
Comment 7 Marcia Knous [:marcia - use ni] 2007-02-23 13:15:51 PST
Kim: Yes, I can confirm that I received your form. I cc'd Axel on this bug, not sure if he needs to comment here or not.

(In reply to comment #6)
> Marcia:
> 
> Have you received the CVS form? Even though it is send by snail mail, it should
> not take this long.
> 

Comment 8 Kim Ludvigsen 2007-03-05 10:15:18 PST
Marcia:

Any news about what's needed? There's a string freeze for Sunbird 0.5 March 12th, and it would be nice if I can begin translating and uploading at that time.
Comment 9 Marcia Knous [:marcia - use ni] 2007-03-05 13:55:38 PST
Ok, I am passing this bug over to server-ops for account creation. This will be for translating Sunbird/Lightning to danish, and write access to that area only. Over to server-ops->please create this account and add an SSH key.
Comment 10 Jeremy Orem [:oremj] 2007-03-06 11:05:46 PST
Your CVS account has been created.  Your CVSROOT should be:

   ludvig%mail.dk@cvs.mozilla.org:/cvsroot

Don't forget to set your CVS_RSH environment variable to 'ssh'.

If you have any problems connecting, let me know.
Comment 11 Reed Loden [:reed] (use needinfo?) 2007-03-06 11:07:46 PST
Reopening. This account should be for /1l0n, not /cvsroot.
Comment 12 Jeremy Orem [:oremj] 2007-03-06 11:16:19 PST
ludvig%mail.dk@cvs.mozilla.org:/l10n will be your CVSROOT
Comment 13 Marcia Knous [:marcia - use ni] 2007-03-06 11:17:36 PST
Jeremy: This needs to be an l10n account, not a normal cvs account. Can we please make sure Kim has access to the l10n repository? Thanks.
Comment 14 Kim Ludvigsen 2007-03-16 14:56:04 PDT
Jeremy:

I can't make a checkout, it looks as if I don't have write permission. This is from my command prompt:

[U:\Programmer\Tools\CVS\bin]cvs -d:ext:ludvig%mail.dk@cvs.mozilla.org:/l10n co
-P -r MOZILLA_1_8_BRANCH l10n/da
Enter passphrase for key 'k:\programmer\security\kim/.ssh/id_dsa':
cvs checkout: Updating l10n/da
cvs checkout: failed to create lock directory for `/l10n/l10n/da' (/l10n/l10n/da
/#cvs.lock): Permission denied
cvs checkout: failed to obtain dir lock in repository `/l10n/l10n/da'
cvs [checkout aborted]: read lock failed - giving up
Comment 15 Kim Ludvigsen 2007-03-25 09:07:48 PDT
Never mind!

I will no longer translate Mozilla products.

Translating is easy, but the process to know what to translate, how to translate and how to get the translation uploaded is just too cumbersome - and nerdy. And that said by a "nerdy" journalist that has been writing about computers and technology for more than 10 years, and that has written a couple of books about computers and technology (one of them about Firefox and Thunderbird).

I used 1 hour to translate the strings for Sunbird 0.5 - I have used more than 8 hours trying to get it uploaded. I tried to get help here, but to no avail.

After getting a one-time help uploading, there is errors. I don't know where the errors is, and even if I did, I wouldn't be able to upload corrections. The result is, we will probably not have a danish Sunbird 0.5. 

Please revoke my permission to use my time fighting with Bugzilla, SSH, CVS and the lack of information on Mozilla's homepage.
Comment 16 Marcia Knous [:marcia - use ni] 2007-03-25 12:57:49 PDT
Kim: Sorry you had so much difficulty in trying to get your translation uploaded. I would hate to have all that hard work go to waste, and would like to work with you to get the technical problems resolved. Let me know if still want to go forward. Thanks.

(In reply to comment #15)
> Never mind!
> 
> I will no longer translate Mozilla products.
> 
> Translating is easy, but the process to know what to translate, how to
> translate and how to get the translation uploaded is just too cumbersome - and
> nerdy. And that said by a "nerdy" journalist that has been writing about
> computers and technology for more than 10 years, and that has written a couple
> of books about computers and technology (one of them about Firefox and
> Thunderbird).
> 
> I used 1 hour to translate the strings for Sunbird 0.5 - I have used more than
> 8 hours trying to get it uploaded. I tried to get help here, but to no avail.
> 
> After getting a one-time help uploading, there is errors. I don't know where
> the errors is, and even if I did, I wouldn't be able to upload corrections. The
> result is, we will probably not have a danish Sunbird 0.5. 
> 
> Please revoke my permission to use my time fighting with Bugzilla, SSH, CVS and
> the lack of information on Mozilla's homepage.
> 

Comment 17 Kim Ludvigsen 2007-03-25 15:38:38 PDT
I have asked in the forum of MozillaDanmark if anybody else will take over. Hopefully someone will answer. I will not use any more of my time on this. And even if I would I couldn't, as I'm away from my computer from today until after the l10n freeze of Sunbird 0.5. When I asked for help 9 days ago, there was still plenty of time.

Of course, I would like to know if the error in uploading was on my part, or if it was the rights that was not set correctly on the server. But no matter what, you (Mozilla) should seriously consider making it easier for translators. A website with explanations and help would be a very good thing. It should include something like the following:

How to find out if anyone is already working on the translation.

Where to get the files for the various projects and versions. This should always be updated, so one can easily find where to checkout the version to translate.

How to get the files:
    using a command line
    using one or two GUI programs like TortoiseCVS
 
How to translate - telling about which files to translate and about strings.

Which code page to use and how to save in that code page.

How to get cvs write access - the existing pages is actually ok.

How to upload
    Using command line
    Using one or two GUI programs like TortoiseCVS

How to check if the files have been checked in using Bonsai (I still haven't figured that one out).

How to check for building errors - explanation of the meaning of the report in the tinderbox.

There might be tools that I haven't found - if so they should be included.

How to get help if one still has a problem.

Whom to contact, that can help uploading, if the translator haven't permission to upload. 

Some of the above mentioned can be found various places at Mozilla's website. It should all be placed together, so it is easy to find, and easy to use. The text - and images - on the pages should be easy to understand and not full of unexplained words and phrases that only a nerd understand. Not every possible translator is a nerd and not every possible translator uses Linux.

Take a look at the page MozillaDanmark has made to help those that want to translate extensions:
http://www.mozilladanmark.dk/udvidelser/guidetiloversaettelse/
You will probably not understand the text, but you should be able to see, that it is a very easy to follow step by step guide.


Comment 18 Axel Hecht [:Pike] 2007-03-26 09:39:44 PDT
Kim, your expectations are unrealistic. In particular when localizing a software somewhere between 0.3 and 0.5. In addition to calendar being a side project in its early stages, the documentation you request will never work for everybody, and thus *must* not be on a single page. No one would ever read that.

Giving up without any poking is the wrong thing to do in Mozilla land, too, and no matter what we'd do right now, you'd get unhappy about something else next week. Or, given that calendar just broke their string freeze, would be already.

I'm leaving it up to lilmatt and sskøder to make a call here, but Kim has already publicly retreated, http://forum.mozilladanmark.dk/viewtopic.php?t=2636, there doesn't seem to be that much room for discussion anymore.
Comment 19 Kim Ludvigsen 2007-03-26 10:04:54 PDT
Axel, I did not give up without a fight. And Sunbird is not the first project I have translated. I also translated Nvu to danish, but then I did not have to fight with CVS. The problem is not with Sunbird or its early state. As I wrote, the translation took only an hour. The problem is with the CVS system, and the lack of help - on the website and here.

The suggestions with the help pages is not that much for me, but for others who otherwise will never be able to help translating. I have many years training with computers, most people call me a nerd, but I still have had big problems and used a lot more time than necessarily - there is something wrong when the translations is the smallest part of the work.

I would of course not expect the help pages to be on one page only, that is why I wrote "site". And no, I'm not a whiner that always has to complaint. I'm complaining here out of desperation, because I wanted Sunbird in danish. SSkr°der can tell you, I'm normally not shying away from work.

If anyone is wondering how I'm answering, when I said I would be away from my computer: I'm in Hungary, and I was lucky enough to borrow a computer, and to have Internet access down here. So I'm controlling my home computer with VNC :-)
Comment 20 Kim Ludvigsen 2011-07-26 10:24:48 PDT
I was never successful in getting writing access. Can we please try again?

I have a feeling that it went wrong from the start, as the account was set up for cvsroot and that something went wrong when changing that to 1l0n.

I have tried several times during the years to make it work. And several experts have tried to help me, but to no avail. 

Maybe the solution is to close the account and begin again from scratch? Except for the paper work that is.

I have generated a new public key which you will find attached in the next message.

Please notice that I have changed e-mail address since the first try. New a-mail address is ludvigs@kimludvigsen.dk
Comment 21 Kim Ludvigsen 2011-07-26 10:26:13 PDT
Created attachment 548518 [details]
New public key

Please use this key for the account.
Comment 22 Axel Hecht [:Pike] 2011-07-26 10:33:17 PDT
Erica, do you have the contributor form for Kim on file?

It might be an old one, so if we need the new one filled out again, that'd be good to know?
Comment 23 Dave Miller [:justdave] (justdave@bugzilla.org) 2011-07-26 19:06:44 PDT
The previous CVS account (for ludvig@mail.dk) still existed, but had been disabled.  Given that we're starting from scratch and the previous attempt had issues, I deleted it.  Might as well set it up from scratch to make sure we get it right.

There is already an LDAP account for ludvig@kimludvigsen.dk, (note one less 's' in the username than the one in Bugzilla), which has an SSH key on it that matches neither the one that had been on the account I deleted nor the one attached to this bug.  This LDAP account does not have access to any source code repos currently though (looks like it doesn't actually have access to anything?)
Comment 24 Dave Miller [:justdave] (justdave@bugzilla.org) 2011-07-26 19:08:05 PDT
Erica: please assign this back to me once we've verified we have a current contributor form on file.
Comment 25 Kim Ludvigsen 2011-07-26 23:58:39 PDT
Dave Miller: Yes, the e-mail address is new, I don't use the old one(s) anymore. The old key SSH died with an old computer a long time ago, and rather than trying to find it somewhere in a backup, I wanted to start from scratch.
Comment 26 Jesper Kristensen 2011-08-17 03:22:44 PDT
ping!
Comment 27 Kim Ludvigsen 2011-08-24 12:58:00 PDT
Erica, did you find my contributor form?
Comment 28 Erica McClure 2011-08-26 16:26:54 PDT
Kim, can you re-send it. I'm not finding in our files.
Comment 29 Kim Ludvigsen 2011-08-26 22:38:29 PDT
Committers agreement send by e-mail.
Comment 30 Erica McClure 2011-08-29 01:09:16 PDT
I have received Kim's Committer's Agreement.
Comment 31 Axel Hecht [:Pike] 2011-08-29 02:47:56 PDT
Back to Dave per comment 24.
Comment 32 Dave Miller [:justdave] (justdave@bugzilla.org) 2011-08-30 01:48:26 PDT
OK, sounds like everything's straight for getting access. A lot has happened over the course of this bug, so if you don't mind, could someone give me a summary of what's actually needed now?  Just an Hg account with l10n access?  Can I use the account in the second paragraph of comment 23 or rename it to the new name?  What email should be used for the new account? etc.  Thanks!
Comment 33 Kim Ludvigsen 2011-08-30 01:59:56 PDT
Hg account with l10n access.

Maybe it is better to start all over instead of using the old account mentioned in comment 23? Just to be sure that the problems with the old account will not resurface.

E-mail: ludvigs@kimludvigsen.dk
Comment 34 Dave Miller [:justdave] (justdave@bugzilla.org) 2011-09-13 11:08:14 PDT
OK, the existing LDAP account has been renamed to ludvigs@kimludvigsen.dk, the ssh key has been replaced with the one on this bug, and hg and scm_l10n access has been granted.

The password has been reset and mailed to you.
Comment 35 Dave Miller [:justdave] (justdave@bugzilla.org) 2011-09-13 11:08:33 PDT
And my apologies for the delay :|

Note You need to log in before you can comment on or make changes to this bug.