Attachment "Save As" will pop up "Opening ..." dialog instead of "Save" dialog

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: alfred.peng, Unassigned)

Tracking

1.8 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
 
(Reporter)

Updated

12 years ago
Summary: Attachment "Save As" will pop up → Attachment "Save As" will pop up "Opening ..." dialog instead of "Save
(Reporter)

Comment 1

12 years ago
Thunderbird version 2 beta 2 (20070124) on Solaris 10.

1.  Go find and subscribe to an RSS feed which includes enclosures in its articles. For example: http://www.actsofvolition.com/rss contains sound files as enclosures.
2. Check the thread pane listing the articles.
3. View an article with an enclosure.
4. In the attachment pane, bring up the context menu for any of the enclosures and  select "Save As".

Actual result:
"Opening ..." dialog shows up.

Expected result:
Save dialog shows up.
OS: SunOS → Solaris
Summary: Attachment "Save As" will pop up "Opening ..." dialog instead of "Save → Attachment "Save As" will pop up "Opening ..." dialog instead of "Save" dialog

Comment 2

12 years ago
Reproduced with 2b1-0125, Win2K.

Since that site is serving its enclosures very slowly (over a modem, I'd guess), I didn't let it run to completion -- does it actually save the file or execute it once the D/L is complete?
OS: Solaris → All
Hardware: PC → All
(Reporter)

Comment 3

12 years ago
The D/L is slow here. I'd guess that if I choose "Open with...", the file will be opened with some application. For "Save to Disk", it will be saved.

The problem here is the wrong dialog shows up.

Comment 4

10 years ago
related to bug 261801, specific here for rss case. more general there.

Comment 5

10 years ago
The test case in comment #1 is no longer valid, the site now uses HTTP: links that hand off to Fx.
Assignee: mscott → nobody

Updated

10 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Version: 2.0 → 1.8 Branch

Comment 6

7 years ago
this is not (any longer?) valid.  the .ogg in the feed will bring up the Open dialog and ask Always do this (since there is a valid mimetype) and subsequently bring up Save As for the type once it's registered.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.