When I create a non-recurring event it duplicates to the immediate next day

RESOLVED DUPLICATE of bug 337191

Status

--
major
RESOLVED DUPLICATE of bug 337191
12 years ago
12 years ago

People

(Reporter: justakiwi, Unassigned)

Tracking

Details

Attachments

(1 attachment)

954 bytes, application/octet-stream
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061208 FreeBSD/i386 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.9a1) Gecko/20061226 Calendar/0.3

When I create a single event that is NOT recurring, it is duplicated to the immediate next day as well as the correct day. e.g.event to occur on Jan 29th (10.30 - 11.30 am) - also appears on Jan 30th.

If I delete the duplicate entry, it also deletes the correct one.

I did find a similar bug already reported and resolved but that referred only to recurring events. This is happening with one-off events.

Reproducible: Always

Steps to Reproduce:
1. Create new non-recurring event
2. Event appears on both the correct day AND the next day
3.


Expected Results:  
If one creates a single non-recurring event, it should not appear on incorrect days/dates
Please export an event that shows the problem to iCalendar format and attach in this bug. What is the number of the resolved bug you are referring to?
What timezone do you configured in Sunbird?
Carren, does the event is shown on correct time or not? I think this might be a duplicate of Bug 337191. What is the timezone set in your OS and what timezone is configured in Sunbird?
(Reporter)

Comment 3

12 years ago
Stefan, firstly ... I see no way to save the event file in ical format. I did get your email explaining how to do that, but there is absolutely NO drop down/expansion for "save as". The only fields that appear in the dialogue box are: name, save in folder, browse folders, cancel and save. When I hit "save" the file is automatically saved as HTML, no further options appear anywhere. I don't know if this is a BSD thing or not - I'll post at their forums and ask there.

Meanwhile, re the correct time. In actual fact you're right - the time is NOT appearing as I set it. I created an event for Jan 29th from 10:30 - 11:30 am, but the actual time showing in the event is Mon 29th 2007 23:30 - Tues 30th Jan 2007 00:30. 

My OS timezone is set to current local time (Pacific, Auckland), as is the timezone in Sunbird. We are currently in daylight saving time, which the OS is automatically detecting, but perhaps Sunbird isn't? I don't really see that that would make a difference to this particular event though.

I looked at the bug you quoted above and this does look like a dupe of that one. The one I mentioned in my first post, was closer to mine, but was apparently only relevant for recurring events, unlike mine. Unfortunately I didn't note the bug number and I can't find it now.

Anyway, if this is indeed a dupe of 337191 feel free to close this. Thanks for your help!
(Reporter)

Comment 4

12 years ago
Created attachment 253123 [details]
Faulty event

Found it! You were right - hidden somewhere in that "browse folders" option.
Whiteboard: [qa discussion needed]

Comment 5

12 years ago
Sounds like a problem caused by the issue in bug 337191, marking as a DUPE.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 337191
Whiteboard: [qa discussion needed]
You need to log in before you can comment on or make changes to this bug.