Closed Bug 368271 Opened 13 years ago Closed 13 years ago

Add-on installer should allow the user to allow a certain site only once

Categories

(Toolkit :: Add-ons Manager, enhancement)

x86
Linux
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 252830

People

(Reporter: caleb.marcus, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20060601 Firefox/2.0.0.1 (Ubuntu-edgy)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20060601 Firefox/2.0.0.1 (Ubuntu-edgy)

When an extension-installation link is clicked on from a site that is not on the software installation allow list, a bar appears from the top, allowing the user to add the site to their trusted list. There should be an option to allow that site to install software only once, rather than the only option being to add the site to the trusted list.

Reproducible: Always

Steps to Reproduce:
1. Go to a site that's not on the software installation allow list that offers an extension (http://www.efinke.com/addons/url-fixer/ is an example)
2. Click the Install link on the site
Actual Results:  
The only option is to add the site to the allow list. There's no option to allow that site to install software only once.

Expected Results:  
There should be an option to allow a site to install an extension just that one time, rather than having to add it to the trusted sites list and remove it later.
The whitelist is actually part of xpinstall and not the extension manager and there is already a bug under xpinstall though I don't have the time atm to track it down
Whiteboard: DUPEME
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 252830
Duplicate of bug: 252830
Whiteboard: DUPEME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.