mirror sites for bookmarks

RESOLVED WONTFIX

Status

SeaMonkey
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
18 years ago
6 years ago

People

(Reporter: André Langhorst, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

(Reporter)

Description

18 years ago
It should be possible to assign mirror sites for bookmarks, these should be used
when the first (second,third...) site is not reachable
example: www.php.net (sometimes not reachable, most up to date, official site)
mirror1: www.php3.de (always available, updated after www.php.net)
mirror2: and so on...

OPTION: would be if mozilla could remember that it´s on a mirror site, and if a
download/page is not available (404 for example) mozilla could try to deliver it
from a mirror site

Comment 1

18 years ago
Would the time it takes to implement this feature justify its use?  Don't get 
me wrong, I understand your desire for it, it's just that I've never heard 
anyone ask for this before and can't imagine it being that widespread.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: mirror sites for bookmarks → [RFE] mirror sites for bookmarks
(Reporter)

Comment 2

18 years ago
1) the first part shouldn´t be very hairy to implement: ONE additional field 
(most simple solution) or an additional page where one or MORE fields to assign 
mirror sites, on clicking a bookmark should be checked if page loading was 
successful, if not it should be checked if mirror sites are available, if yes 
mozilla should try to load them - DONE
2) perhaps nobody thought at it because nobody was aware that mozilla 
potentially could be used at public terminals with direct internet connection, 
where it´s most important that the desired page is always available, if a page 
suffers under heavy load and isn´t reachable anymore (definable time out period 
would be a nice feature too :) ) mozilla could decide to use another working 
page...

Updated

18 years ago
Target Milestone: --- → Future

Comment 3

18 years ago
Reassigning 79 Bookmarks bugs to Ben.  I was told this was going to be done 
shortly about two months ago, but it clearly hasn't been.  I think that's long 
enough for all these bugs to remain assigned to nobody.

Feel free to filter all this spam into the trashcan by looking for this string 
in the message body: ducksgoquack
Assignee: slamm → ben
Netscape Nav triage team: this is not a Netscape beta stopper.
Keywords: nsbeta1-

Comment 5

17 years ago
*** Bug 86182 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Priority: P3 → P5
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW

Comment 7

17 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Updated

16 years ago
Summary: [RFE] mirror sites for bookmarks → mirror sites for bookmarks

Comment 8

15 years ago
If this will eventually be done, we could also consider adding an option to
always pick a random URL from the mirror list - to distribute the load evenly.
(Reporter)

Comment 9

15 years ago
I guess this never will be done, I retract this one
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 10

15 years ago
This RFE is still valid. Lack of progress in not a good reason to close a bug.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 11

15 years ago
seems like a good enough reason to me, but whatever.

you might as well use a tab group and open the folder as tabs, whichever one
loads first, use. close the rest.
Assignee: bugs → p_ch
Status: REOPENED → NEW
QA Contact: claudius → seamonkey.bookmarks
Product: Browser → Seamonkey

Comment 12

13 years ago
Reassigning as per Bug #32644
Assignee: p_ch → nobody

Comment 13

6 years ago
Despite this idea looks interesting, I think that's not possible with current sqlite storage for bookmarks, any other opinions?
Priority: P5 → --
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INVA/WONT?]

Comment 14

6 years ago
This is a vary edge case. I agree WONTFIX
Status: NEW → RESOLVED
Last Resolved: 15 years ago6 years ago
Resolution: --- → WONTFIX

Updated

6 years ago
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 INVA/WONT?] → [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.