Fail to find plugins under MOZ_PLUGIN_PATH

RESOLVED FIXED

Status

()

Core
Plug-ins
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Boying Lu, Unassigned)

Tracking

Trunk
x86
OpenSolaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Re-produce steps:
1. export MOZ_PLUGIN_PATH=$MOZ_PLUGIN_PATH:/usr/sfw/lib/mozilla/plugins
2. firefox

expected result:
firefox can find all the plugins under /usr/sfw/lib/mozilla/plugins

actual result:
firefox can't find those plugins
(Reporter)

Comment 1

11 years ago
Created attachment 252901 [details] [diff] [review]
skip leading PATH_SEPARATORS in the MOZ_PLUGIN_PATH
Attachment #252901 - Flags: review?(benjamin)
(Reporter)

Comment 2

11 years ago
The root cause is that MOZ_PLUGIN_PATH is empty before step 1, so the MOZ_PLUGIN_PATH is set to ":/usr/sfw/lib/mozilla/plugin".
nsPathsDirectoryEnumerator uses it as a directory name which doesn't exist.

Comment 3

11 years ago
This really belongs in core->plugins
Component: Plugin Finder Service → Plug-ins
Flags: review?(benjamin)
Product: Firefox → Core
QA Contact: plugin.finder → plugins
(Reporter)

Updated

11 years ago
Attachment #252901 - Flags: review?(brendan)
Comment on attachment 252901 [details] [diff] [review]
skip leading PATH_SEPARATORS in the MOZ_PLUGIN_PATH

Bouncing to Benjamin, XPCOM owner.

/be
Attachment #252901 - Flags: review?(brendan) → review?(benjamin)

Updated

11 years ago
Attachment #252901 - Flags: review?(benjamin) → review+

Comment 5

11 years ago
FIXED on trunk.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.