Window stops repainting properly after being minimized.

RESOLVED FIXED in mozilla1.9alpha6

Status

()

Core
Widget: Cocoa
--
major
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: mossop, Assigned: Josh Aas)

Tracking

Trunk
mozilla1.9alpha6
x86
Mac OS X
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Not sure whether this belongs in Layout or GFX or what, but I have an issue with Mac Minefield no longer repainting properly after being minimized to the dock.

STR:

1. Open the url given, observe the fantastic animations.
2. Minimize the window to the dock.
3. Open the window again.

At this point for me all the animations have stopped. If you scroll up and down the page the animations do happen and every time it scrolls a bit the backgrounds seem to be repainted again.

This affects the whole window, not just the webpage, the throbber, changing tabs etc. all do not repaint right after having been minimized.

Closing the window and opening a new one is enough to get a working window.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a2pre) Gecko/20070125 Minefield/3.0a2pre ID:2007012504
I was about to file this with the following steps (today's trunk build on Tiger Mactel):

1) Open a new window
2) Load www.w3.org
3) Scroll down so you can see the "CSS" link in the left sidebar
4) Click the minus in the titlebar to minimize the window
5) wait 3 seconds (dunno that you need to, but whatever)
6) click the icon in the dock to bring back the window.  If this fails
   due to bug 364326, ctrl-click and select "Open"
7) Click the "CSS" link

EXPECTED RESULTS: Load page with CSS specs

ACTUAL RESULTS:  The addressbar changes, then the tab throbber stops and painting stops happening.  I can force paints by switching tabs using Ctrl-pgup/Ctrl-pgdown, but that's the only way I've found.

This looks like widget to me, and I don't think we can ship 1.9 like this...
Assignee: nobody → joshmoz
Component: Layout → Widget: Cocoa
Flags: blocking1.9?
QA Contact: layout → cocoa
Works in a fairly current no-Cocoa build, fails in an early-October Cocoa build, so it certainly looks like widget, and I wouldn't be surprised if it's related to bug 364326 (I'm not quick enough to get one un-minimized without forcing it with the context menu to be sure, though).

Comment 3

11 years ago
Is this possibly Mac Intel only ? I can't reproduce any of those problems here on my PPC Macs (10.4.8 and 10.3.9). And no Intel Mac to test.
I'm using a Mactel, yes.
(Reporter)

Comment 5

11 years ago
I don't seem to be seeing this in my current build

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a3pre) Gecko/20070222 Minefield/3.0a3pre ID:2007022204 [cairo]
(Reporter)

Comment 6

11 years ago
(In reply to comment #5)
> I don't seem to be seeing this in my current build

Well scratch that. It seems less reproducible than it was but it's definately still a problem.
Flags: blocking1.9? → blocking1.9+

Comment 7

11 years ago
I see this in latest trunk and with a PPC Mac so it is still happening and is not Intel-only.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a5pre) Gecko/20070502 Minefield/3.0a5pre ID:2007050204 [cairo]
(Assignee)

Updated

11 years ago
Target Milestone: --- → mozilla1.9alpha6
This bug (368336) and bug 364326 only happen when Firefox is
relaunched, and appear to be caused by bug 377166 (which prevents the
browser from seeing "events" generated by the Dock menu).
Depends on: 377166
I've posted a preliminary fix for bug 377166 that fixes this bug (the
problems described in comment #0 and comment #1 no longer happen, even
when Minefield has been relaunched).
Fixed by patch for bug 377166.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.