Closed Bug 368433 Opened 15 years ago Closed 15 years ago

many items on status bar led to html content pane size wrong calvulated

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 204743

People

(Reporter: martin, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

If there are many Items on the status bar, requiring more space than available, the content area for the html display is wrongly extended.
This will be visible if you have a small page requiring just 200 or 300 pixel (like a popup) and set the overall window size to make the html pane exactly the size needed.
The content will be displayed outside the visible area (no scrollbar) The content  right side aligns with the virtual end of the statusbar

Imagine window of 310 x 210 pixel, holding a table (Right aligned or centered) of 300 x 200. the table should be drawn in the visible part of the window.
If the elements in the statusbar are 500 pixel width, the table will be moved 200 pixel to the right, and be displaed outside the visible area.

Note that the rendering of the htm depends on the content of the statusbar





Reproducible: Always

Steps to Reproduce:
1) install and configure modules(like header spy) that occupy a big amount of space in the status bar

2) save and load the following html
<html><body>
<div align="right">
<table width="250" bgcolor="111111">
<tr><td>text</td><td>text</td></tr>
</table>
</div>
</body></html>

3) resize the browser.
It should be bigger than 300 pixel, but to small to hold all the elements on the status bar


Actual Results:  
even so th html could be fully displayed in the visible area of the browser. it s moved to the right, and drawn outside the users view.

There is no scrollbar, and if this is a non-resizable popup, it is impossible to see the content

Expected Results:  
html fully drawn in te visible area

-
Related to/dupe of bug 204743?
indeed, sorry
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 204743
You need to log in before you can comment on or make changes to this bug.