Last Comment Bug 368478 - Disable "Open the Search Tab in the Sidebar when search is invoked" by default
: Disable "Open the Search Tab in the Sidebar when search is invoked" by default
Status: RESOLVED FIXED
[fixed by bug 410613]
:
Product: SeaMonkey
Classification: Client Software
Component: Preferences (show other bugs)
: Trunk
: All All
: -- normal (vote)
: seamonkey2.1b2
Assigned To: Robert Kaiser (not working on stability any more)
:
Mentors:
Depends on: 410613
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-28 05:07 PST by Manuel Reimer
Modified: 2010-12-08 06:38 PST (History)
5 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch [Superseded by bug 410613] (2.75 KB, patch)
2007-01-28 05:19 PST, Manuel Reimer
csthomas: approval‑seamonkey1.1.1+
Details | Diff | Review

Description Manuel Reimer 2007-01-28 05:07:34 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.8.0.9) Gecko/20061222 SeaMonkey/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.8.0.9) Gecko/20061222 SeaMonkey/1.0.7

In current SeaMonkey builds, by default SeaMonkey opens the sidebar when a google search is invoked. I don't think the majority of users really need the sidebar open if searching with google.

I got requests from "SeaMonkey-Newbies" several times, which didn't know about how to get rid of this "auto-opening" of the sidebar. They don't know why SeaMonkey does such unusual things.

As this is definetly a feature, only needed by a few SeaMonkey users, it should be disabled by default.

Reproducible: Always

Steps to Reproduce:
1. Create a new profile
2. Surf to www.google.com
3. Search for something
Actual Results:  
Sidebar will pop up and displays the current search results

Expected Results:  
Sidebar shouldn't pop up. The user decided to search with google and he wants to view the results in the web page, he opened. There is no need to open the sidebar automatically by default.
Comment 1 Manuel Reimer 2007-01-28 05:19:18 PST
Created attachment 253086 [details] [diff] [review]
Patch
[Superseded by bug 410613]
Comment 2 neil@parkwaycc.co.uk 2007-01-28 06:39:32 PST
You thought that was bad? It used to open when you did a google search using the Google website. Now it only opens when you use the search UI.
Comment 3 Manuel Reimer 2007-01-28 07:05:26 PST
It still opens if I'm searching from address bar.

This means, that I get the result in both: Sidebar and content area (the website).

Searching from address bar is a pretty nice feature (just Ctrl+L, enter search term and "Enter"), but I don't think we have to open the web page *and* the sidebar by default. If someone likes the search result in the sidebar, then I think he would also start the search from there. If someone really wants the sidebar to pop up when searching from address bar, then he is able to enable this feature.
Comment 4 neil@parkwaycc.co.uk 2007-01-28 09:12:41 PST
Hmm, I always thought that the sidebar reads its results from the web page.
It just saves you from going back to the web page to check out other results.
Comment 5 Manuel Reimer 2007-01-28 10:19:25 PST
Yes, you are right. If I'm searching from sidebar, then my current site is gone and google is opened...

I don't think "bundling" the URL bar search with the sidebar by default is a good idea.

Searching from URL bar is a pretty nice thing. It allowes to initiate a search just with a few shortcuts (Ctrl + L + Cursor up, enter search term, Ctrl + Enter).

Searching on Sidebar is a bit difficult. You only get a "one-liner" which seems to be the page title for most entries. At least I also need the few lines of information about the page, provided by google, to find out if this page is what I'm searching for. So I'll still have to switch back to google, to find more hits, which could be interesting.

If we bundle the two, then SeaMonkey-Newbies may decide to not use the URL-bar-search, as they don't like the sidebar to pop up.

As mentioned above, some people, who got SeaMonkey installed by me, asked me about how they can disable the sidebar. They didn't know about or didn't find the checkbox to turn this off.
Comment 6 Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2007-01-28 10:57:06 PST
I'm pretty sure this is a dupe of a bug that has a patch that neither Neil nor jag were willing to sr.  Hopefully you have better luck.
Comment 7 Manuel Reimer 2007-01-29 07:17:05 PST
I don't know, but I'm still waiting for answer about if I'll get review.

I still think we should not bundle URL-bar search and sidebar search by default. These two are two features, which *may* be combined, but this shouldn't be done by default, as this may cause users not to use powerful URL-bar search as they don't like the Sidebar to pup-up all the time.

And sidebar search needs update/rewrite as it's useless if we don't have the information about the webpages, offered by the search engine.

As we have a very powerful tabbed browsing support, the better way is to open all the entries on the sarch engine in new tabs into background. Then you also have the search result in view until you decide to view your loaded results.
Comment 8 Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2007-02-13 15:47:32 PST
Comment on attachment 253086 [details] [diff] [review]
Patch
[Superseded by bug 410613]

a=me for sm1.1.1, hopefully this gets reviewed.
Comment 9 Serge Gautherie (:sgautherie) 2007-11-18 05:59:17 PST
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b2pre) Gecko/2007111802 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

While this would make the sidebar less discoverable,
I agree I have yet to learn in which cases this feature would help me :-<
Then, I guess, by default, I would concur to this "bug".

If we want to keep this feature enabled,
may be we could add a (first-time) page/notification/dialog/whatever, something like
"Sidebar is set to auto-open on search, to disable this feature unselect View > Show/Hide > Sidebar, or click here"...
May be with a "Don't ask me again" option.
Like the "secure/unsecure mix" alert or the <about:config> warning...
Comment 10 Serge Gautherie (:sgautherie) 2007-11-18 06:36:12 PST
(In reply to comment #9)
> "Sidebar is set to auto-open on search, to disable this feature unselect View >
> Show/Hide > Sidebar, or click here"...

Rather:
"Edit > Preferences... > Browser > Internet Search > ..." :-]
Comment 11 Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2007-11-18 08:18:23 PST
That's a lot to ask users to remember. We should just kill it by default.
Comment 12 Serge Gautherie (:sgautherie) 2008-06-11 15:03:47 PDT
(Filter "spam" on 'prefs-nobody-20080612'.)
Comment 13 Serge Gautherie (:sgautherie) 2008-06-11 16:39:29 PDT
Neil, ping ?
Comment 14 Robert Kaiser (not working on stability any more) 2010-07-22 11:51:29 PDT
Manuel, could you update this one for the current code? I really think we should take it now for SeaMonkey 2.1 - esp. in the light that this sidebar isn't that useful any more and could potentially stop working, given someone comes around to switch us to opensearch.
Comment 16 Manuel Reimer 2010-10-25 10:14:21 PDT
Comment on attachment 253086 [details] [diff] [review]
Patch
[Superseded by bug 410613]

>Index: xpfe/bootstrap/browser-prefs.js
>===================================================================
>RCS file: /cvsroot/mozilla/xpfe/bootstrap/browser-prefs.js,v
>retrieving revision 1.58
>diff -u -8 -p -r1.58 browser-prefs.js
>--- xpfe/bootstrap/browser-prefs.js	20 Jan 2007 20:44:45 -0000	1.58
>+++ xpfe/bootstrap/browser-prefs.js	28 Jan 2007 13:17:56 -0000
>@@ -99,17 +99,17 @@ pref("browser.download.progressDnlgDialo
> pref("browser.download.finished_download_sound", false);
> pref("browser.download.finished_download_alert", false);
> pref("browser.download.finished_sound_url", "");
> pref("browser.download.autoDownload", false);
> pref("browser.download.lastLocation", true);
> 
> // various default search settings
> pref("browser.search.defaulturl", "chrome://navigator-region/locale/region.properties");
>-pref("browser.search.opensidebarsearchpanel", true);
>+pref("browser.search.opensidebarsearchpanel", false);
> pref("browser.search.opentabforcontextsearch", false);
> pref("browser.search.last_search_category", "NC:SearchCategory?category=urn:search:category:1");
> pref("browser.search.mode", 0);
> // basic search popup constraint: minimum sherlock plugin version displayed
> // (note: must be a string representation of a float or it'll default to 0.0)
> pref("browser.search.basic.min_ver", "0.0");
> pref("browser.urlbar.autocomplete.enabled", true);
> pref("browser.urlbar.clickSelectsAll", true);
>Index: suite/browser/browser-prefs.js
>===================================================================
>RCS file: /cvsroot/mozilla/suite/browser/browser-prefs.js,v
>retrieving revision 1.59
>diff -u -8 -p -r1.59 browser-prefs.js
>--- suite/browser/browser-prefs.js	20 Jan 2007 20:45:11 -0000	1.59
>+++ suite/browser/browser-prefs.js	28 Jan 2007 13:17:59 -0000
>@@ -100,17 +100,17 @@ pref("browser.download.progressDnlgDialo
> pref("browser.download.finished_download_sound", false);
> pref("browser.download.finished_download_alert", false);
> pref("browser.download.finished_sound_url", "");
> pref("browser.download.autoDownload", false);
> pref("browser.download.lastLocation", true);
> 
> // various default search settings
> pref("browser.search.defaulturl", "chrome://navigator-region/locale/region.properties");
>-pref("browser.search.opensidebarsearchpanel", true);
>+pref("browser.search.opensidebarsearchpanel", false);
> pref("browser.search.opentabforcontextsearch", false);
> pref("browser.search.last_search_category", "NC:SearchCategory?category=urn:search:category:1");
> pref("browser.search.mode", 0);
> // basic search popup constraint: minimum sherlock plugin version displayed
> // (note: must be a string representation of a float or it'll default to 0.0)
> pref("browser.search.basic.min_ver", "0.0");
> pref("browser.urlbar.autocomplete.enabled", true);
> pref("browser.urlbar.clickSelectsAll", true);
Comment 17 Yhn 2010-12-08 05:51:08 PST
Turn it into an option, rather than disable it by default
Comment 18 Robert Kaiser (not working on stability any more) 2010-12-08 06:38:33 PST
(In reply to comment #17)
> Turn it into an option, rather than disable it by default

It always has been an option, and it still is. No idea what you are talking about.

Note You need to log in before you can comment on or make changes to this bug.