Firefox crashes when saving [@ ntdll.dll + 0x64ed1 (0x7c974ed1)]

RESOLVED WORKSFORME

Status

()

Core
Networking
--
critical
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: Frederic Da Vitoria, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

When saving a link destination (one of my last example was with a link to a pdf), if I change the destination folder and choose My Documents, FF crashes immediately (no warning dialog). The session restores correctly after, but TalkBack doesn't kick in. This happens for Save link destination, as well as Save image as. I have a hunch this happens because the path to My Documents contains accented characters (if I use "My Computer" then navigate to an unaccented folder, no problem), but it does not happen all the times.

Reproducible: Sometimes

Steps to Reproduce:
1. right click on a link to a document or an image
2. in the Save dialog, choose My Documents
3. see the crash
(Reporter)

Comment 1

12 years ago
I have been using FF for years now and I believe this bug is new to at least v2
Have you tried clearing your download history?
(Reporter)

Comment 4

12 years ago
I just cleared it. I will report if this bug reappears or not. Wait for a few days, though, since the bug is not systematic.
No response from reporter --> INCOMPLETE
Reporter, if you still see this problem then please reopen this bug. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

11 years ago
I've had it again a few days ago. Now I am using FF 2.0.0.4 I sent 2 crash reports with CallBack. I had the opportunity to check: if I browsed to the folder I wanted, FF crashed. If I selected the default directory, the download worked perfectly. This has happened quite a few times, as far as I remember always with pictures (although maybe it is essentially with pictures that I tend to change the destination folder).
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(Reporter)

Comment 7

11 years ago
I just tried with the exact same configuration (I rembered where the pics were) and I couldn't reproduce the bug. Last time, I could reproduce it systematically. Next time I stumble on it, I am going to try clearing the history to test.
(Reporter)

Comment 8

11 years ago
After re-reading my first post, I should note the following things: the bug does not happen only on pics, and this time, the destination folder does not contain any accented character. Sorry, I am not making it easier!
Can you please launch talkback.exe and tell us the TalkBackIDs you have submitted? Thanks!
Severity: normal → critical
Keywords: crash
Version: unspecified → 2.0 Branch
(Reporter)

Comment 10

11 years ago
I didn't even know this could be done. I should have guessed, though! Here they are: TB32787091G, TB32787087Z
Incident ID: 32787091
Stack Signature	ntdll.dll + 0x64ed1 (0x7c974ed1) 8d64897a
Product ID	Firefox2
Build ID	2007051502
Trigger Time	2007-06-03 03:32:21.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	ntdll.dll + (00064ed1)
URL visited	http://www.photos-balades.com/Blog/dotclear/index.php?2007/05/07/171-enfin-le-canon-s5-is
User Comments	Same as before. I will try now without browsing. If you don't get another feedback, it will mean it will have worked!
Since Last Crash	99 sec
Total Uptime	30749 sec
Trigger Reason	Unknown exception 0xc0000022
Source File, Line No.	N/A
Stack Trace 	
ntdll.dll + 0x64ed1 (0x7c974ed1)
ntdll.dll + 0x4243c (0x7c95243c)
ntdll.dll + 0x104b (0x7c91104b)
nsOutputStreamReadyEvent::OnOutputStreamReady  [mozilla/xpcom/io/nsStreamUtils.cpp, line 198]


Incident ID: 32787087
Stack Signature	ntdll.dll + 0x64ed1 (0x7c974ed1) 9c67be80
Product ID	Firefox2
Build ID	2007051502
Trigger Time	2007-06-03 03:27:11.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	ntdll.dll + (00064ed1)
URL visited	http://www.photos-balades.com/Blog/dotclear/index.php?2007/05/07/171-enfin-le-canon-s5-is
User Comments	Saving a jpg picture to disk. I had borwsed my disk directory structure to find the appropriate directory and I just clicked "Save" to save the pic. The picture's link address was http://cweb.canon.jp/camera/powershot/s5is/data/S5IS_l4.jpg. I re-did the
Since Last Crash	30650 sec
Total Uptime	30650 sec
Trigger Reason	Unknown exception 0xc0000022
Source File, Line No.	N/A
Stack Trace 	
ntdll.dll + 0x64ed1 (0x7c974ed1)
ntdll.dll + 0x4243c (0x7c95243c)
ntdll.dll + 0x104b (0x7c91104b)
nsSocketTransportService::Run  [mozilla/netwerk/base/src/nsSocketTransportService2.cpp, line 625]
nsThread::Main  [mozilla/xpcom/threads/nsThread.cpp, line 134]
kernel32.dll + 0xb683 (0x7c80b683)
Summary: Firefox crashes when saving → Firefox crashes when saving [@ ntdll.dll + 0x64ed1 (0x7c974ed1)]
Can you please make a new firefox profile:
- http://kb.mozillazine.org/Profile_manager
(Do not delete your existing profile!)
and see if this problem still persists. Thanks!

Updated

11 years ago
Component: General → Networking
Product: Firefox → Core
QA Contact: general → networking
Version: 2.0 Branch → 1.8 Branch
(Reporter)

Comment 13

11 years ago
I created a new empty profile, and I will use it to test the problem next time the bug appears.
(Reporter)

Comment 14

11 years ago
The bug just occured for the first time in 3 months. I immediately switched to the empty profile and tested it. It did not occur again. Of course, one test is not enough to decide, so I will go on testing.
Frederic, I'm sorry you hit crashes for which Talkback wasn't able to give us enough information.  If you're still hitting them, please file new bugs with information from our new crash reporting system (Breakpad), which you can find by loading about:crashes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago9 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 16

9 years ago
I haven't experienced this problem for months. Maybe since I switched to FF3. So from my point of view, you can consider this bug as DISAPPEARED :-)
Resolution: INCOMPLETE → FIXED
Great to hear :)
Resolution: FIXED → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ ntdll.dll + 0x64ed1 (0x7c974ed1)]
You need to log in before you can comment on or make changes to this bug.