cannot display full width grid inside tabpanel when using it in a sub xbl binding

RESOLVED INVALID

Status

()

Core
XUL
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: marc dassonneville, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

I discovered that when including a "custom" binding inside a tabpanel, this binding couldn't take the whole width.

For this test case, I have made 2 small bindings : etudes & etudes_sub
etudes content is composed of a tabpanel which include etudes_sub.

etudes sub is composed of a grid flex="1", so it should be a "full width grid".

To illustrate the problem, I have made other bindings :
 - etudes_with_sub_flex which call etudes_sub with attribute flex="1"
 - etudes_with_sub_style_width_100 which call etudes_sub with attribute style="width:100%"
 - etudes_all_in_one which is an exact copy of etude, with the inline copy pasted code of etude_sub

the url above shows in order :
 - etudes
 - etudes_with_sub_flex
 - etudes_with_sub_style_width_100
 - etudes_all_in_one

source code of the bindings is in "etudes.xml"

Reproducible: Always

Steps to Reproduce:
1. just go on the url & look at the result.
2. You should see 3 differents results for the 4 tests instead of 1 unique ?!

Actual Results:  
it displays 3 differents results.
 - 1 full width
 - 1 centered
 - 1 left align

details :
 - etudes_all_in_one binding displays is correct
 - etudes binding may seems wrong (don't the subgrid flex=1 should extend it ?)
 - etudes_with_sub_flex binding center the content ?!
 - etudes_with_sub_style_width_100 does the same thing as etudes, but has a stranger behaviour with some more complex examples (I have reduced the test case here).

Expected Results:  
these 4 tests should display the same thing shouldn't they ?!

It was tested on firefox 2.0.0.1 but also on the the 3.0a2pre nighlty build.

Maybe I missed the way of calling subbindings ... but this seems strange

Comment 1

11 years ago
Test 4 isn't the same as test 1. Test 1 has an extra inflexible box with the tag 'etudes_sub' that isn't present in test 4. You can confirm this with the dom inspector.

(Reporter)

Comment 2

11 years ago
yes, but test 2 & 3 adds flex=1 or width=100% on the subbinding "etudes_sub", and it's still not 100% of the width size, as if using a subbinding instead of inline xul code makes flex or width useless.

Comment 3

11 years ago
I think that the result of test 2 is normal : flex isn't applied because etudes_sub tag isn't a xul tag, and so its "display" property is set to "inline" by default. If you want to turn it into a xul box, you should set display:-moz-box; on etudes_sub in your CSS stylesheet, or you should put the xul namespace prefix on the tag (<xul:etudes_sub />). And then the result of test 2 will be the same as test 4.

So I don't think there are bugs here. Except the result of test 2 in your example, which is strange (in fact the grid is displayed outside the etudes_sub box). However i guess this is because of the mix of box models, which cause often strange results :-)

I think we can change the bug resolution from UNCONFIRMED to INVALID...
Component: General → XP Toolkit/Widgets: XUL
Product: Mozilla Application Suite → Core

Comment 4

11 years ago
After discussion with Marc on irc, he is agree to invalidate this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: general → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.