Importer (Win Eudora, Address Book) mailing lists imported both as list and individual entries.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
12 years ago
10 years ago

People

(Reporter: mdudziak, Assigned: gwenger)

Tracking

x86
Windows XP

Details

(Reporter)

Description

12 years ago
The problem is that when you import a 'mailing list' (a nickname that has multiple addresses) from Eudora, the Penelope importer create a mailing list with all the addresses (See Note #1 below) but also creates individual entries for each address in the list (not expected).

To reproduce:

- In Eudora's Address Book create an entry:
Nickname: list_test
Addresses:
     address1@domain1.com
     address2@domain2.com
     address3@domain3.com
     address4@domain4.com

- Import the Address Book into Penelope 
- Note in Penelope you have a list called "list_test" which may or may not have addresses associated with it (See Note #1 below). If it has addresses, it will have all the addresses shown above, as would be expected.
- Note in Penelope you also have 4 individual entries for the 4 addresses associated with the nickname. This is not expected.



Note #1: For reasons I have not determined, importing a 'group' nickname sometimes created a mailing list in Penelope, and sometimes does not. By 'does not' I mean that a mailing list entry is created in Penelope, but there are no addresses in the addresses section. Other times, the list of addresses IS populated...
(Assignee)

Comment 1

12 years ago
This appears to be necessary for how the AB works. If you create a new mailing list in TB / Penelope, you'll get the same behavior - individual entries will be added for each recipient (if they don't already exist).

Therefore I'm calling this not a bug in importers. If necessary we can add a new bug filed against the AB and see if people vote for it - i.e. does anyone care that mailing lists must be comprised of other AB cards.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.