Last Comment Bug 368660 - copying repeating item to new date to continue repeating.
: copying repeating item to new date to continue repeating.
Status: RESOLVED DUPLICATE of bug 345607
:
Product: Calendar
Classification: Client Software
Component: Provider: ICS/WebDAV (show other bugs)
: Sunbird 0.3
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-29 22:07 PST by JamesAmos
Modified: 2007-05-15 06:15 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description JamesAmos 2007-01-29 22:07:19 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: 3.0

I am a college student... I use icalx.com to host my calender and see it remotely (me and my girlfriend share it)... I put my schedual in the calender as weekly events, classes Mon, Wed, Fri repeating till spring break.  Then I copied the event to after the spring break and told it to repeat again, Mon, Wed, Fri (no changes) to the end of the semester.  close sunbirg after it asks for my user name and password when i logs in.  Open sunbird back up, The Original event (before spring break) is there, but not the second event.  I ended up having to create a whole knew event and re-enter all the information and tell it to repeat.  This happened for all five classes that I did this too.  

Reproducible: Always

Steps to Reproduce:
1.create an event starts at 9:00 - 9:50 goes from Jan 8 to March 5th. Have it repeat Weekly, Mon's and Tue's. 

2. Then Copy Feb 28th to March 12th.  Tell it to repeat till April 25th Mon, Tues.

Actual Results:  
After all these steps are performed, the "copied" event from March 12th to April 25th (after closing and reopening program) is GONE, its just not there.  You have to Create a BRAND NEW event (CANNOT COPY) in order to get it to save.

Expected Results:  
All events would have been there through there repeated dates.

*Note, I only use remote Calenders using icalx.com, may or may not make a difference, I wouldn't think it would.  

** I am also using an Intel Mac (10.4.8) and I do know that Sunbird is only written so far for the Motorola processor, and is using rosetta in order to translate the code on the fly.  So, that also could be an issue.
Comment 1 Stefan Sitter 2007-05-15 06:15:19 PDT

*** This bug has been marked as a duplicate of bug 345607 ***

Note You need to log in before you can comment on or make changes to this bug.