Give option to explicitly set format preference to both "plain text" or "HTML"

VERIFIED DUPLICATE of bug 42038

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
enhancement
VERIFIED DUPLICATE of bug 42038
18 years ago
13 years ago

People

(Reporter: BenB, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-])

(Reporter)

Description

18 years ago
Right now, you can only set the format preference of a recipient to "Prefers
HTML"* (default false). There should also be an option to explicitly set the
preference to "plain text", so this user will always get plain text, no matter,
what other preferences are sat or what the user answered to intelligent send
(should it trigger due to other recipients).

Work to be done:
- Minor change in front end to either a 3-state checkbox or option boxes.
- (Minor?) Change in address book backend, so it can store the new value.
- Minor change to migration to reflect the address book database change.

*this actually reads "Send email as plain text (no html)" currently, which is
wrong IMO, because this will trigger intelligent send and won't work at all, if
the user sat the global preference to "always send HTML".
(Reporter)

Comment 1

18 years ago
Bug 36879 is about changes in the sending logic to always honor this pref, if
set to either "plain text" or "HTML" (not "don't know").

nsbeta2 nomination - this is important interop.
Keywords: nsbeta2

Comment 2

18 years ago
reassigning to ducarroz
Assignee: putterman → ducarroz

Comment 3

18 years ago
[nsbeta2-]. This is a feature which isn't on our PRD
Whiteboard: [nsbeta2-]
(Assignee)

Updated

18 years ago
Severity: normal → enhancement
Status: NEW → ASSIGNED
Target Milestone: --- → M17

Comment 4

18 years ago
Moving to future milestone.
Target Milestone: M17 → Future
(Reporter)

Updated

17 years ago
Keywords: mozilla1.0
(Reporter)

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 42038 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
verified/dup
Status: RESOLVED → VERIFIED
QA Contact: lchiang → fenella
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.