[META] content site userAgent sniffers don't respect mozilla/5.0 user agent

RESOLVED WORKSFORME

Status

Core Graveyard
Tracking
P2
normal
RESOLVED WORKSFORME
19 years ago
2 years ago

People

(Reporter: Claudius Gayle, Assigned: ekrock's old account (dead))

Tracking

({meta})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
I've come across a number of 'bugs' now that only after much work prove to not be bugs at all.

As we know, many sites employ javascript to 'sniff' the browser and then serve up different html based on what they detect.

A few sites don't get this quite right and send broken HTML when they encounter Mozilla/5.0.

Prove it you say?
If you take the HTML that Nova recieves and feed it to Seamonkey it works fine.
If you take the HTML seamonkey recieves and feed it to Nova it is broken in the same
way in both browsers.

What we see looks like a layout bug. In actuality it is a website serverside error.

Sites where this problem have come up: www.ibm.com, www.quicken.com, and I suspect www.planetquake.com.
bugs that have been filed because of this (that I've seen) 1793, 2960, 2961, 2963, 2965.
(Reporter)

Updated

19 years ago
Priority: P3 → P2
(Reporter)

Comment 1

19 years ago
Upping priority as I think we win a lot if we can get this taken care of whereas we get hurt on Top 100 sites thorugh no fault of our
own if we don't.

Updated

19 years ago
Assignee: chofmann → chriss
Summary: servers sending broken html based on mozilla/5.0 user agent → Get top content sites to respect mozilla/5.0 user agent
Target Milestone: M6

Comment 2

19 years ago
This is a well known type of problem we encounter with
each new release of the browser.

re-assigning to chriss.  cc ekrock and micheall.
marketing and all need to start spamming
the major content sites that sniff for user agents and
get them to start liking 5.0 browsers.

There will be a ton of sites like this. Lets add the sites
and the list of known contacts at each of these sites to this bug.
(Reporter)

Updated

19 years ago
OS: Mac System 8.5 → All
(Reporter)

Comment 3

19 years ago
updating url to point to a nice testcase. there are two pages here n4, for the HTML served to Mozilla/4.0 and n5 for HTML served
to Mozilla/5.0 user agent.

Updated

19 years ago
Assignee: chriss → ekrock

Comment 4

19 years ago
assigning to ekrock.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
QA Contact: 3853 → 3849

Comment 5

19 years ago
Has any progress been made on this front yet?  Please don't keep the list a
secret...  I'm begging you, make it public.  I'd like to see a list of these
sites too--I want to start e-mailing them as well.

This is important guys--let me tell you, I have already started e-mailing the
people behind some of my favorite sites, to try and get them to make their sites
use standard HTML, CSS, etc.  The reason I think this is so serious is this: in
every single case I've tried so far, the maintainers of the sites didn't listen
to me...  They just don't give a darned about individuals who seem to be
requesting support for an "oddball browser."  All they seem to care about is
what will satisfy the largest numbers in terms of market demographics.
Therefore, I think we need to mass mail them as a community.  On my own, it was
pretty bad--in one case, I got no response to my query at all, and in another,
the guy basically told me that he refused to do anything about it, because he
didn't think it was worthwhile doing anything about it, since so few people
would notice any difference.

So please, HELP THIS EFFORT--after all, it seems this is indeed a PR thing more
than it is a technical matter, and I believe we can only win if the entire
Mozilla community participates.  So let us do this as a community effort...  Go
Mozilla heads!!

Updated

19 years ago
Target Milestone: M6 → M8

Comment 6

19 years ago
erik is getting something up on mozilla.org soon.
if there are links to webmaster on this or any other site
feel free to contact them and reqesting that they
start make their site recognize 5.0 user agents and
standards compiliant.
(Assignee)

Comment 7

19 years ago
All such cases should be pointed to this Nav5/IE5-aware client sniffer:
http://developer.netscape.com/docs/examples/javascript/browser_type.html

Encourage people to put this text in their SIG files:
Is your JavaScript ready for Nav5 and IE5?
Get the latest JavaScript client sniffer at
http://developer.netscape.com/docs/examples/javascript/browser_type.html

I've just spammed this info to every JS mailing list and newsgroup I'm aware of
but I'd welcome more suggestions.  Can anyone suggest a way to get in touch with
the webmasters at all Top 100 quicker than looking for an email contact on each
site one at a time?

Assign all confirmed userAgent-detection bugs to me and I'll evangelize the fix
to the webmasters.

Comment 8

19 years ago
As to getting the word out quickly to Top 100: I smell a wonderful opportunity
here--this is the kind of activity that benefits very much from parallelism, and
this is something that the Internet is *VERY* good for as demonstrated by Open
Source development. <g>  Therefore, may I suggest trying to get a story run on
Slashdot, maybe??  Make use of that interesting "Slashdot effect?"

I'll try to get Slashdot to print a story if you want...  Just say the word.
They do seem to like Mozilla news items occasionally...  And some of the
Slashdot readers LOVE the "Slashdot effect."

GO MOZILLA!! GO GO GO MOZILLA!

Comment 9

19 years ago
One other thing--again, this is an organizational thing more than technical
thing, but now that Bugzilla does dependencies, may I suggest that we now start
marking all bugs that are in the Bugzilla database and traceable to this to be
marked as dependent on this bug?  That might help to show which bugs are really
because of this problem.

Sincerely,
ZuperDee of Penguin Land
(Assignee)

Updated

19 years ago
Depends on: 1793, 2960, 2961, 2963, 2965

Updated

19 years ago
No longer depends on: 1793, 2960, 2961, 2963, 2965

Comment 10

19 years ago
Think the bug dependencies got a little reversed...  If I'm not mistaken, those
bugs depend on this one, not this one on them. :-)

Updated

19 years ago
Blocks: 1793, 2960, 2961, 2963, 2965
(Assignee)

Updated

19 years ago
No longer blocks: 1793, 2960, 2961, 2963, 2965
(Assignee)

Updated

19 years ago
Depends on: 2960
(Assignee)

Updated

19 years ago
Depends on: 2961
(Assignee)

Updated

19 years ago
Depends on: 2963
(Assignee)

Updated

19 years ago
Depends on: 2965
(Assignee)

Updated

19 years ago
Depends on: 1793

Updated

19 years ago
Blocks: 7733

Comment 11

19 years ago
Darn...  I think *MY* head was twisted today.  You were right--those bugs depend
on this one, not the other way around.  I'm terribly sorry...  I think I'm
losing my head or something.

Updated

19 years ago
No longer depends on: 1793, 2960, 2961, 2963, 2965

Updated

19 years ago
Blocks: 1793, 2960, 2961, 2963, 2965

Comment 12

19 years ago
*** Bug 7733 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Blocks: 7732
(Reporter)

Updated

19 years ago
Blocks: 7734

Comment 13

19 years ago
*** Bug 7734 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
No longer blocks: 1793, 2960, 2961, 2963, 2965, 7732, 7733, 7734
Summary: Get top content sites to respect mozilla/5.0 user agent → [META] content site userAgent sniffers don't respect mozilla/5.0 user agent
(Assignee)

Comment 14

19 years ago
NOTE: I'M FIXING DEPENDENCIES SO THEY POINT THE RIGHT WAY PER CHOFMANN.  DON'T
CHANGE THE DEPENDENCY DIRECTION! ;->  This META bug depends on the individual
bugs.  When filing additional specific sites with userAgent problems, make this
META bug depend on them.
(Assignee)

Updated

19 years ago
Depends on: 1793, 2960, 2961, 2963, 2965, 7732, 7733, 7734

Comment 15

19 years ago
Moving all Apprunner bugs past and present to Other component temporarily whilst
don and I set correct component.  Apprunner component will be deleted/retired
shortly.

Updated

19 years ago
No longer depends on: 7733

Updated

19 years ago
Depends on: 5537

Updated

19 years ago
Depends on: 5538
(Assignee)

Updated

19 years ago
Target Milestone: M8 → M15
(Assignee)

Comment 16

19 years ago
Have evangelized this; reassigning to M15 for tracking purposes only.

Updated

19 years ago
Blocks: 7634
(Reporter)

Updated

19 years ago
Depends on: 2550

Updated

19 years ago
QA Contact: beppe → petersen

Updated

18 years ago
Keywords: meta
(Reporter)

Updated

18 years ago
Depends on: 24679

Comment 17

18 years ago
Since this is for tracking only... I'm pushing to M16 to get off the M15 
branching radar.
Target Milestone: M15 → M16
(Assignee)

Comment 18

18 years ago
As this is a tracking meta bug only, moving to M30 to get off our 
milestone-to-milestone radar for a long time.
Target Milestone: M16 → M30
This bug seem to be unused. worksforme
Please reopen if this is wrong
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.