Upgrade developers.m.o MediaWiki

RESOLVED FIXED

Status

RESOLVED FIXED
12 years ago
6 years ago

People

(Reporter: BenB, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
The login form of dev.m.o
http://developer.mozilla.org/en/docs/index.php?title=Special:Userlogin
breaks the Firefox password manager. It's fixed in current versions. See
http://bugzilla.wikimedia.org/show_bug.cgi?id=8841 .

We use 1.5.6, which is "very old". Please upgrade. Thanks.

Comment 1

12 years ago
I'm not sure there isn't already a bug on this somewhere. Devmo is blocked from upgrading by some plugins that aren't compatible with newer versions of mediawiki. 

CC'ing devmo people for more detail.
Yes, this is a dup of something in the MDC infrastructure component.  Don't have time to find it right now, but I'll at least fix the classification.
Assignee: server-ops → nobody
Component: Server Operations → Infrastructure
Product: mozilla.org → Mozilla Developer Center
QA Contact: justin → infrastructure
Version: other → unspecified
(Reporter)

Comment 3

12 years ago
> this is a dup of something in the MDC infrastructure component.

Reading over the full list twice, I didn't find a dup or anything like it (in that component).
(Reporter)

Comment 4

12 years ago
FWIW, if upgrading is not an option, then this bug shall be morphed into a request to upgrade or fix the login page only.
Upgrading will happen, it just won't happen right away.  (See project status meeting notes from the other week, f.e.)
We have begun work in earnest on this upgrade process; we have a full duplicate of MDC running on http://developer-stage.mozilla.com now, running MediaWiki 1.9.3.  Everything appears to be working at a glance, but we could use some testing.  If anyone would like to contribute to that testing effort, it would be greatly appreciated.
(In reply to comment #6)
> We have begun work in earnest on this upgrade process; we have a full duplicate
> of MDC running on http://developer-stage.mozilla.com now, running MediaWiki
> 1.9.3.

You mean http://developer-stage.mozilla.org? :)
Yes, that's what I mean.  This is what happens when I type URLs from memory instead of copying and pasting them.  Bad Sheppy!
We're now running MediaWiki 1.9.3!  Yay!  Closing this.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Component: Deki Infrastructure → Other
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.