Last Comment Bug 368920 - Darken the background for Message Grouping (Group by Sort) headers
: Darken the background for Message Grouping (Group by Sort) headers
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: unspecified
: All All
-- enhancement with 1 vote (vote)
: Thunderbird 43.0
Assigned To: alta88
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-31 17:16 PST by Karel Koubek
Modified: 2015-09-05 11:24 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Current appearance of headers (47.48 KB, image/png)
2007-01-31 17:19 PST, Karel Koubek
no flags Details
Header in Thunderbird 3.0.4 are not very clear (80.88 KB, image/png)
2010-04-02 14:08 PDT, Vincent (caméléon)
no flags Details
groupedHeaderTheme.patch (4.05 KB, patch)
2015-08-28 09:41 PDT, alta88
richard.marti: review-
Details | Diff | Splinter Review
groupedHeaderTheme.patch (4.85 KB, patch)
2015-08-29 10:34 PDT, alta88
richard.marti: review+
Details | Diff | Splinter Review
groupedHeaderTheme2.patch (1.41 KB, patch)
2015-08-30 07:45 PDT, alta88
richard.marti: review+
Details | Diff | Splinter Review

Description User image Karel Koubek 2007-01-31 17:16:41 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: 2 pre (2007013104)

The 'Group by Sort' headers are quite illegible in the current implementation - their color blend with the surrounding gray lines and it's difficult to quickly orientate between them.

Reproducible: Always



Expected Results:  
To help the matter, darker gray tone could be used for the headers, or even some light pastel color.
I would also retain only one color for the headers, irrespective of the header position between lines - further helps orientation (The darker gray used for headers between two white lines is just fine and should be default for all headers).
Comment 1 User image Karel Koubek 2007-01-31 17:19:00 PST
Created attachment 253560 [details]
Current appearance of headers
Comment 2 User image Steve Simms 2008-08-22 09:21:26 PDT
Confirming.
Comment 3 User image Vincent (caméléon) 2010-04-02 14:08:00 PDT
Same problem here: header should have a different  background than the grey background use for the other lines (I attach another print-screen).
Comment 4 User image Vincent (caméléon) 2010-04-02 14:08:54 PDT
Created attachment 436762 [details]
Header in Thunderbird 3.0.4 are not very clear
Comment 5 User image Vincent (caméléon) 2010-04-03 12:35:53 PDT
Still there in Lanikai/3.1b1 :-(
Comment 6 User image Karel Koubek 2010-07-20 17:31:41 PDT
As a stop-gap solution I propose the following user CSS that I've been using since the Thunderbird 2.x times:

/*Grouped by Sort headers: font */
treechildren::-moz-tree-cell-text(dummy){
  color: #112D94 !important;
}

/*Grouped by Sort headers: background */
treechildren::-moz-tree-row(dummy){
  background: #E2E2E6 !important;
}

For those who don't know - simply create a folder named "chrome" in your profile folder and inside it create a file called userChrome.css with these lines of code. Feel free to change the hex color code to your liking.

Maybe the developers could have a look at this and incorporate it? A black bold text against gray background according to Thunderbird color palette couldn't hurt...
Comment 7 User image alta88 2015-08-27 14:38:54 PDT
Yes, the current #F0F0F0 on win and linux is barely visible.  But worse, due to the (odd) rule, even that is overridden for grouped view dummy rows, as it doesn't take into account thread parent/group headers where odd/even doesn't apply:

https://dxr.mozilla.org/comm-central/source/mail/themes/linux/mail/mailWindow1.css#362
https://dxr.mozilla.org/comm-central/source/mail/themes/windows/mail/mailWindow1.css#363

Also, the dummy rules here are not being used, since the column name isn't being set in the backend, and can be removed:

https://dxr.mozilla.org/comm-central/source/mail/themes/shared/mail/mailWindow1.css#43

Paenglab, what do you think? Perhaps something more vibrant can be done to those dummy header rows. (I'm doing some work to make grouped view work better).
Comment 8 User image alta88 2015-08-28 09:41:35 PDT
Created attachment 8654193 [details] [diff] [review]
groupedHeaderTheme.patch


A possible color, feel free to override.  Also, the backend is setting the properties correctly, but the rules in /shared are getting overridden later. The 3 toggles don't work right when used in the header row so need to be hidden.
Comment 9 User image Richard Marti (:Paenglab) 2015-08-28 14:16:57 PDT
Comment on attachment 8654193 [details] [diff] [review]
groupedHeaderTheme.patch

Review of attachment 8654193 [details] [diff] [review]:
-----------------------------------------------------------------

The color is okay. I also thought to use -moz-Dialog before you came with this patch.

The patch doesn't apply on latest trunk. With fixing this and addressing the comments it should get a r+ the next time.

::: mail/themes/linux/mail/mailWindow1.css
@@ +68,5 @@
>    -moz-padding-start: 2px;
>  }
>  
>  treechildren::-moz-tree-row(dummy, selected) {
>    background-color: -moz-Dialog;

Is this still needed? The normal dummy row has now already -moz-Dialog as variable.

::: mail/themes/shared/mail/mailWindow1.css
@@ +60,5 @@
>    -moz-padding-end: 3px;
>  }
>  
>  treechildren::-moz-tree-image(junkStatusCol, dummy) {
> +  list-style-image: none !important;

The correspondentCol is missing.
When you're on this, can you group this selectors together and add comment for what it is? Like:

/* ..... don't show icons on dummy rows ..... */

treechildren::-moz-tree-image(subjectCol, dummy),
treechildren::-moz-tree-image(flaggedCol, dummy),
treechildren::-moz-tree-image(junkStatusCol, dummy) ,
treechildren::-moz-tree-image(correspondentCol, dummy),
treechildren::-moz-tree-image(unreadButtonColHeader, dummy) {
  list-style-image: none !important;
}

::: mail/themes/windows/mail/mailWindow1.css
@@ +63,5 @@
>    -moz-padding-start: 2px;
>  }
>  
>  treechildren::-moz-tree-row(dummy, selected) {
>    background-color: -moz-Dialog;

Again, ist this still needed?

@@ +327,5 @@
>      background-image: url("chrome://messenger/skin/icons/row.png");
>      background-position: bottom;
>      background-repeat: repeat-x;
>    }
> +  #threadTree treechildren::-moz-tree-row(dummy, odd) {

Please a empty line between these rules.
Comment 10 User image alta88 2015-08-29 10:34:17 PDT
Created attachment 8654531 [details] [diff] [review]
groupedHeaderTheme.patch


thanks, rebased and all comments fixed.
Comment 11 User image Richard Marti (:Paenglab) 2015-08-29 13:47:29 PDT
Comment on attachment 8654531 [details] [diff] [review]
groupedHeaderTheme.patch

Review of attachment 8654531 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Thank you for the patch.
Comment 12 User image alta88 2015-08-30 07:45:12 PDT
Created attachment 8654602 [details] [diff] [review]
groupedHeaderTheme2.patch


With all groups collapsed, they look too much the same and harder to differentiate; this adds a separation.
Comment 13 User image aleth [:aleth] 2015-09-05 11:23:26 PDT
https://hg.mozilla.org/comm-central/rev/972db835c0e756a0b738106d66437302a348bbe2
Bug 368920 - Darken the background for Message Grouping (Group by Sort) headers. r=paenglab

https://hg.mozilla.org/comm-central/rev/b7472e239aa26967f125577a0887fa236b03b5ba
Bug 368920 - Darken the background for Message Grouping (Group by Sort) headers, part2. r=paenglab a=aleth SM CLOSED TREE

Note You need to log in before you can comment on or make changes to this bug.