Can't store/access different credentials (in the Keychain) for different httpAuth realms on the same host

RESOLVED FIXED in Camino1.5

Status

Camino Graveyard
OS Integration
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Assigned: Stuart Morgan)

Tracking

({fixed1.8.1.3})

unspecified
Camino1.5
PowerPC
Mac OS X
fixed1.8.1.3

Details

(URL)

Attachments

(1 attachment)

fix
16.47 KB, patch
Josh Aas
: review+
Mike Pinkerton (not reading bugmail)
: superreview+
Details | Diff | Splinter Review
STR:

1. Visit a httpAuth realm on a server, log in, and save the login and password
2. Visit another httpAuth realm on the same server
2a. Replace the pre-filled credentials with the appropriate ones for this realm and save
3. Visit the original realm and see the credentials from realm 2 filled in

Note: If you visit the 2 realms in Safari first and save them, Camino will not read those passwords at all, and will prompt you with a blank auth sheet for the first realm you visit.

"Camino Auth Test" - http://www.ardisson.org/smokey/moz/authtest/ - camino:cmtest1
"Chimera Auth Test" - http://www.ardisson.org/smokey/moz/chimera/ - smorgan:imti7an
(Assignee)

Comment 1

11 years ago
Looking at the code, this should be easy to fix. Us not using Safari's entries surprises me though, so I'll have to look into that.
Status: NEW → ASSIGNED
(Assignee)

Comment 2

11 years ago
(In reply to comment #0)
> Note: If you visit the 2 realms in Safari first and save them, Camino will not
> read those passwords at all

Spun into bug 370112, since it's a port issue, not a realm issue.

I'm confident that I can fix this for 1.1, but it's going to rely on the work I did for the security change, so I want to wait for that to land before posting a patch. Pulling to 1.1 though so I don't forget.
Target Milestone: --- → Camino1.1
(Assignee)

Comment 3

11 years ago
Created attachment 257206 [details] [diff] [review]
fix

Uses realm for HTTPAuth. Also fixes a bug I noticed in the form security code where we could attach the initial action host to the wrong entry if we were starting with a non-Camino entry and changing the account.
Attachment #257206 - Flags: review?(joshmoz)

Updated

11 years ago
Attachment #257206 - Flags: review?(joshmoz) → review+
(Assignee)

Updated

11 years ago
Attachment #257206 - Flags: superreview?(mikepinkerton)
Comment on attachment 257206 [details] [diff] [review]
fix

sr=pink
Attachment #257206 - Flags: superreview?(mikepinkerton) → superreview+
(Assignee)

Comment 5

11 years ago
Checked in on trunk and MOZILLA_1_8_BRANCH.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1.3
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.