message searching gives different results when changing the order of the filters

RESOLVED DUPLICATE of bug 383345

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 383345
11 years ago
10 years ago

People

(Reporter: anton janssen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.1.2pre) Gecko/20070119 SeaMonkey/1.1
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.1.2pre) Gecko/20070119 SeaMonkey/1.1

I tried to search in my emails for mails with an attachment _and_ a certain string in the body. When applying the string filter first (with Body contains 'string') and second the attachment filter (Attachment Status is Has Attadchments), and tick the 'Match all of the following' box, seamonkey gives back 5 counts. When reversing the order (but leave the "Match all of the following" box checked), it gives all mails with an attachment. It look like
the second filter (the string appearing in the body) is not applied.

Reproducible: Always

Steps to Reproduce:
1. Go to a mail box with mails with attachments and mails with no attachments)
2. Goto the Search Messages window
3. Select 'Match all of the following' tick box
4. Make first filter: Attachment Status -> is -> Has Attachments
5. Make second filter: Body -> contains -> "your string"
6. Press Search
7. Remove both filters (by pressing Clear)
8. Make first filter: Body -> contains -> "your string"
9. Make second filter: Attachment Status -> is -> Has Attachments
Actual Results:  
The message counts of the two filter orders is different

Expected Results:  
The message counts of the two filters should be equal
(Reporter)

Comment 1

11 years ago
Seamonkey on Windows Sever 2003 works fine.

Comment 2

10 years ago
(In reply to comment #1)
> Seamonkey on Windows Sever 2003 works fine.

seriously?  can you explain how/why?


verified on windows, local folder, by added a third search term, which it couldn't possibly find, but the message was in the results.

duping
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 383345

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
You need to log in before you can comment on or make changes to this bug.