If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

TB hangs when attaching a file, while the address auto-complete is still shown

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
critical
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Michiel, Assigned: Scott MacGregor)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: 2.0.0.1

If you type the first few letters of an emailaddress, and then drop an attachment on the window; TB hangs, the load rises and nothing happens.

Reproducible: Always

Steps to Reproduce:
1. open a new message window
2. type the first few letters of an emailaddress
3. do NOT select one of the suggestions
4. drag a file from the desktop on the 'attachments' dropbox that automatically apears
Actual Results:  
TB hangs, load rises. 

Expected Results:  
Immediate attachment, no hanging

Comment 1

11 years ago
Confirmed on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2pre) Gecko/20070202 Thunderbird/2.0pre ID:2007020204

Though it's not very easy to get in that situation... Seems you have to drop the attachment on the auto-complete popup for the hang to happen.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: hang
OS: Mac OS X → All
Hardware: Macintosh → All
Version: unspecified → 2.0
WFM  in current trunk on vista or XP, as soon as I click the file to select, autocomplete finishes
Severity: normal → critical

Comment 3

9 years ago
I'd say WFM in 2.0.0.14 and 3.0a1 ID:2008050715 NO crash hang etc, vista
(out of focus/click in os, selects proposed .. )

Comment 4

9 years ago
Unable to reproduce in XP or Ubuntu 8.04.  As in wsmwk's case, as soon as I click on the file (including in Linux), the autocomplete dropdown goes away.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.