All users were logged out of Bugzilla on October 13th, 2018

Timezone string not exported in ics

VERIFIED FIXED

Status

VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: aryx, Assigned: mattwillis)

Tracking

Sunbird 0.3.1

Details

(Whiteboard: [verified0.3.1])

Attachments

(1 attachment)

Importing an calendar with timezone string and exporting it results in loosing information, especially the timezone string. See http://litmus.mozilla.org/show_test.cgi?id=2943

Input calendar:

BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
BEGIN:VTIMEZONE
TZID:/mozilla.org/20050126_1/America/Argentina/ComodRivadavia
X-LIC-LOCATION:America/Argentina/ComodRivadavia
BEGIN:STANDARD
TZOFFSETFROM:-0300
TZOFFSETTO:-0300
TZNAME:ART
DTSTART:19700101T000000
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20070201T161705Z
LAST-MODIFIED:20070201T161705Z
DTSTAMP:20070201T161705Z
UID:9d7b433e-b20f-11db-ae39-001451206316
SUMMARY:Argentina Como Riveria feb 12 at 1pm
DTSTART;TZID=/mozilla.org/20050126_1/America/Argentina/ComodRivadavia:
 20070212T130000
DTEND;TZID=/mozilla.org/20050126_1/America/Argentina/ComodRivadavia:
 20070212T140000
END:VEVENT
END:VCALENDAR

Output calendar:

BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
BEGIN:VEVENT
CREATED:20070201T213642Z
LAST-MODIFIED:20070201T213642Z
DTSTAMP:20070201T213642Z
UID:9d7b433e-b20f-11db-ae39-001451206316
SUMMARY:Argentina Como Riveria feb 12 at 1pm
DTSTART:20070212T160000
DTEND:20070212T170000
END:VEVENT
END:VCALENDAR
(Assignee)

Comment 1

12 years ago
Created attachment 253675 [details] [diff] [review]
Fixes "Argentica" typo

This is caused by a typo in the special case conversion code.
("Argentica" instead of "Argentina")
Assignee: nobody → lilmatt
Status: NEW → ASSIGNED
Attachment #253675 - Flags: first-review?(dmose)
Comment on attachment 253675 [details] [diff] [review]
Fixes "Argentica" typo

r=dmose
Attachment #253675 - Flags: second-review+
(Assignee)

Comment 3

12 years ago
Patch checked in on:
  SUNBIRD_0_3_BRANCH
  LIGHTNING_0_3_BRANCH
  MOZILLA_1_8_BRANCH
  trunk

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Flags: blocking-calendar0.3.1+
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Whiteboard: [fixed0.3.1]
Comment on attachment 253675 [details] [diff] [review]
Fixes "Argentica" typo

Removing first‑review?. Patch was already checked in.
Attachment #253675 - Flags: first-review?(dmose)

Comment 5

12 years ago
VERIFIED on 0.3.1 -- Lightning: 2007020304 (Thunderbird: version 2 beta 2
(20070131)) AND on Sunbird: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O;
en-US; rv:1.9a1) Gecko/20070203 Sunbird/0.3.1

(needs Verifying on 0.5)
(Assignee)

Updated

12 years ago
Whiteboard: [fixed0.3.1] → [verified0.3.1]
VERIFIED with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4pre) Gecko/20070406 Calendar/0.5pre.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.