Text field cursor positioning problems (possibly all related)

RESOLVED DUPLICATE of bug 368893

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 368893
11 years ago
11 years ago

People

(Reporter: Neil P. Pena, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070201 Minefield/3.0a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a2pre) Gecko/20070201 Minefield/3.0a2pre

I experience multiple oddities with cursor positioning in a text field that seem to all be related:

(1) If a web page is configured to have a text field focused on page-load, the cursor appears on the right-hand side of the text box until the form field is clicked or characters are entered.

(2) If Ctrl+Home (jump to beginning) is pressed while in a text field, the cursor appears on the right-hand side of the text box, not before the first character.  (For additional fun, try this on a multi-line text box and watch the cursor be as big as the entire height of the box!)  Ctrl+End (jump to end) causes similar results, but only on a single-line text box.  Interestingly, on a single-line text box, when either of those "tricks" is performed, the despite its appearance the cursor seems to end up in a spot in-between the last character and the first character as if they were taped in a loop; Cursor Right from that "rightmost" position puts the cursor between the first and second characters, while Cursor Left from that position puts the cursor between the last and second-to-last characters.

(3) On a single-line text box, if the first character in the line is not visible and Ctrl+Home is pressed, or if the last character in the line is not visible and Ctrl+End is pressed, the cursor does that "jump to the right side of the box" thing and the field does not scroll (the text does not scroll to show the first of last character, whichever one was trying to see.)

Reproducible: Always

Steps to Reproduce:
To reproduce #1:
1. Go to http://www.google.com
2. Notice the cursor starts on the right-side of the box.
3. Click or start typing and the cursor appears in the right place.

To reproduce #2:
1. Start typing in a text field (such as that search box in Google).
2. Press Ctrl+Home or Ctrl+End.
3. Notice the cursor is on the right-side of the box.
4. Press either Cursor Left or Cursor Right.
5. Regardless of what was pressed in Step 2, if Left was pressed, cursor appears between second-to-last and last character.  If Right was pressed, cursor appears between first and second character.

To reproduce #3:
1. Type enough in a text field (such as that search box in Google) that it doesn't all fit in the view.
2. Press Ctrl+Home.  Notice the cursor jumps to the right-side of the box, but doesn't show the first character.
4. Cursor Right.  Notice the cursor goes to where it should be.
5. Press Ctrl+End.  Notice the cursor jumps to the right-side again, but doesn't show the last character.
6. Cursor Left.  Notice the cursor goes to where it should be.
Actual Results:  
See "Steps to Reproduce"

Expected Results:  
Situation 1:
Start with the cursor on the left-side of the box.

Situation 2:
Ctrl+Home should always put the cursor at the start of the text before the first character.  Ctrl+End should always put the cursor at the end of the text after the last character.

Situation 3:
When Ctrl+Home is pressed and first character is not visible, bring it into view.  When Ctrl+End is pressed and last character is not visible, bring it into view.
Sounds like a dupe of Bug 368893.
yeah, looks like it,
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 368893
You need to log in before you can comment on or make changes to this bug.