Open Bug 369065 Opened 14 years ago Updated 2 years ago

Alarm plays only first few seconds of sound file

Categories

(Calendar :: Alarms, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

People

(Reporter: mozilla, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1
Build Identifier: Lightning 0.3 (2006100618) / TB version 2 beta 2 (20070116)

Alarms for events only play the first one to two seconds of the wave file.

Reproducible: Always

Steps to Reproduce:
1) In prefs.js, I have these:
user_pref("calendar.alarms.playsound", true);
user_pref("calendar.alarms.soundURL", "file:///N:/Entertainment/Music/Other/sounder.wav");
user_pref("calendar.previousweeks.inview", 0);
user_pref("calendar.timezone.local", "/mozilla.org/20050126_1/America/New_York");

"calendar.alarms.soundURL" should point to your own wave file that is preferably ten or more seconds long.

2) In Lightning (month view), create a new event for today with an event time of at least two minutes from now.  (I'm using a remote .ics calendar via WebDAV to contain the event.)

3) In the same dialog, click the Alarm dropdown and choose Custom.  Choose "1 Minute Before".  Click OK and wait.
Actual Results:  
At exactly one minute before the event, the alarm reminder dialog appears on the screen and the wave file plays for one to two seconds then stops abruptly (long before the wave file should have finished playing).

Expected Results:  
The wave file should have finished playing completely.

Because the wave file is only playing for one to two seconds, it makes it more likely that I will not hear it if I'm not sitting at my computer.

This could *possibly* be related to comment #3 in bug:  https://bugzilla.mozilla.org/show_bug.cgi?id=350275#c3

(and thus also affect Sunbird)
(In reply to comment #0)
> This could *possibly* be related to comment #3 in bug: 
> https://bugzilla.mozilla.org/show_bug.cgi?id=350275#c3
> 
> (and thus also affect Sunbird)
> 

I agree- I can still reproduce problem described in bug 350275. 
Component: Lightning Only → Alarms
QA Contact: lightning → alarms
Summary: Alarm plays only first 1 to 2 seconds of wave file (Lightning) → Alarm plays only first 1 to 2 seconds of sound file
This problem seems to be specific to when an alarm fires.  I have no other problems playing wave files in Thunderbird.  The entire wave file also plays perfectly when I preview it in Lightning's options ("Tools > Options > Lightning > Alarms > Preview").
Confirmed in latest SB 0.5 nightly

Mozilla/5.0 (Windows; U; Windows NT 6.0; sk; rv:1.8.1.4pre) Gecko/20070501 Calendar/0.5pre
I tried this on a Mac. It looks as though all the previous attempts were on Win. I went into the Calendar app preferences and set the sound to an mp3 file. When alarms go off, I hear nothing. Is there anything else I need to do to make this testable?
It's possible that mp3 files are not supported.  I tested one in Lightning's options ("preview") and it didn't play at all in Windows either.  However, wave files play for one or two seconds and then stop (using a test event on my calendar).
Pete, could you please test with the latest trunk / 0.8pre nightlies and see if the issue still occurs?
Hi Gary, the problem still exists in Lightning 0.8pre 2008-02-29.
Duplicate of this bug: 447781
This is fixed on my computer with TB3.0b2 / Lightning 1.0pre.
(In reply to comment #9)
> This is fixed on my computer with TB3.0b2 / Lightning 1.0pre.

Marking WFM per comment #9. Hurray!
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
For sure alarm duration now is longer than 2 seconds that I got with Lightning 0.9, but I tried many times on Lightning 1.0pre with a wav file 15 seconds long, and it sounds only for about 5 seconds (rarely until 10 seconds). Even the sound preview in options doesn't work fine, sometimes it sounds all the file's duration, sometimes less, sometimes only the first half.
Can somebody else verify that?

Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.9.1b4pre) Gecko/20090331 Lightning/1.0pre 20090331 Shredder/3.0b3pre
> For sure alarm duration now is longer than 2 seconds that I got with Lightning
> 0.9, but I tried many times on Lightning 1.0pre with a wav file 15 seconds
> long, and it sounds only for about 5 seconds (rarely until 10 seconds).

Confirmed.  My normal wave file plays for about one or two seconds so I thought everything was fixed.  I just tried with a twenty-second wave file and it stops randomly after five to fifteen seconds, as you said.

Thunderbird 3.0b2 / Lightning 1.0pre 2009-03-28
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Alarm plays only first 1 to 2 seconds of sound file → Alarm plays only first few seconds of sound file
Duplicate of this bug: 504211
Please retest with a latest nightly, we are on 1.9.2 now, so things might have been fixed in the meanwhile (if this is a toolkit bug)
I've just tested with 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a2pre) Gecko/20100224 Lightning/1.1a1pre Shredder/3.2a1pre
and nothing has changed. The same as comments #11 #12.
Sound preview on Option dialog seems a bit longer, but the alarm has a random duration.
I've just switched from WinXP to Ubuntu 10.4 Linux and can't reproduce the problem.  My twenty-second wave file plays completely.  Tested it twice.  Maybe the problem is specific to MS Windows.  Using TB 3.1.1 and Lightning 1.0 beta 2.

I just want to tell whomever fixed this issue that I really really really (how many "really's" am I allowed?) really really appreciate it!!! I have a 45 second sound clip I have used in TB for years... well, I guess it's been 9 years since this is the bug report I have been watching :D It always cut off after a few seconds, but I never changed the sound just in case it was ever fixed... and you did :D I can now hear the whole thing and it makes me very very happy :D

Kudos to whomever!

You need to log in before you can comment on or make changes to this bug.